GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » Fairroot » External Packages » problem with external packages (problem with unpacking gtest)
problem with external packages [message #19509] Tue, 06 September 2016 17:54 Go to next message
Alexandros is currently offline  Alexandros
Messages: 51
Registered: January 2014
Location: KVI
continuous participant
From: *kvi-cart.rug.nl
I have a problem trying to install fairroot.
After the ./configure.sh I get this error:

*** Unpacking gtest-1.7.0.zip ..............
--E-- Cannot unpack package gtest

Any help??

Thanks
Re: problem with external packages [message #19510 is a reply to message #19509] Tue, 06 September 2016 21:58 Go to previous messageGo to next message
Tobias Stockmanns is currently offline  Tobias Stockmanns
Messages: 489
Registered: May 2007
first-grade participant
From: *netcologne.de
Try to download it manually and replace the gtest-1.7.0.zip file in the FairRoot folder (which is not properly downloaded) with your manually downloaded version.
Re: problem with external packages [message #19511 is a reply to message #19510] Wed, 07 September 2016 10:05 Go to previous messageGo to next message
Florian Uhlig is currently offline  Florian Uhlig
Messages: 424
Registered: May 2007
first-grade participant
From: *gsi.de
Hi,

unfortunately the old download location of the gtest package disappeared which results in the reported problem.

There are now new FairSoft patch releases jul15p7, nov15p7, and may16p1 which solve the problem. Please use one
of the mentioned versions. Also the dev branch has been corrected.

Ciao

Florian
Re: problem with external packages [message #19513 is a reply to message #19511] Wed, 07 September 2016 12:44 Go to previous messageGo to next message
Alexandros is currently offline  Alexandros
Messages: 51
Registered: January 2014
Location: KVI
continuous participant
From: *kvi-cart.rug.nl
I tried may16p1 version.
It passed the point of my previous problem, and it did go a long way.
But now i get this one:

In file included from /home/apostolou/fairsoft_may16p1/tools/root/math/vc/include/Vc/Memory:30 :0,
from /home/apostolou/fairsoft_may16p1/tools/root/math/vc/include/Vc/IO:24,
from /home/apostolou/fairsoft_may16p1/tools/root/math/vc/include/Vc/Vc:23,
from /home/apostolou/fairsoft_may16p1/tools/root/math/vc/src/trigonometric.cp p:20:
/home/apostolou/fairsoft_may16p1/tools/root/math/vc/include/Vc/avx/inter leavedmemory.tcc: In substitution of 'template<class S1, class IT1, class IT2> void ROOT::Vc::AVX::Vector<T>::gather(const S1*, const EntryType* const S1::*, IT1, IT2, ROOT::Vc::AVX::Vector<T>::MaskArg) [with S1 = <missing>; IT1 = <missing>; IT2 = <missing>]':
/home/apostolou/fairsoft_may16p1/tools/root/math/vc/include/Vc/avx/inter leavedmemory.tcc:359:39: required from here
/home/apostolou/fairsoft_may16p1/tools/root/math/vc/include/Vc/avx/inter leavedmemory.tcc:359:39: internal compiler error: in strip_typedefs, at cp/tree.c:1374
v4.gather(m_data, m_indexes + I(4));
^
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://bugs.opensuse.org/> for instructions.
make[2]: *** [math/vc/trigonometric_AVX+XOP+FMA4.cpp.o] Error 1
make[1]: *** [math/vc/CMakeFiles/Vc.dir/all] Error 2
make: *** [all] Error 2
**** Checking libraries in /home/apostolou/fairsoft_may16p1/buildfairsoft/lib ****
*** ERROR: root could not be created.
create a symbolic linking for Vc library ....
libVc.a not found in lib dirctory
*** End installation of external packages with Errors***


Re: problem with external packages [message #19523 is a reply to message #19513] Thu, 08 September 2016 13:09 Go to previous messageGo to next message
Alexandros is currently offline  Alexandros
Messages: 51
Registered: January 2014
Location: KVI
continuous participant
From: *kvi-cart.rug.nl
The same problem also with nov15p7...

Is it me or there is something wrong??
Re: problem with external packages [message #19524 is a reply to message #19523] Thu, 08 September 2016 13:34 Go to previous messageGo to next message
Florian Uhlig is currently offline  Florian Uhlig
Messages: 424
Registered: May 2007
first-grade participant
From: *gsi.de
Hi Alexandros,

I think this is a problem with the compiler. The VC which is inside ROOT has problems with newer compilers.

Which compiler do you use?

Ciao

Florian
Re: problem with external packages [message #19525 is a reply to message #19524] Thu, 08 September 2016 13:43 Go to previous message
Alexandros is currently offline  Alexandros
Messages: 51
Registered: January 2014
Location: KVI
continuous participant
From: *kvi-cart.rug.nl
I think thats what you ask

gcc version 5.3.1 20160301 [gcc-5-branch revision 233849] (SUSE Linux)
Previous Topic: Compiling ROOT6 with gcc>5
Next Topic: Compilation error root in FairSoft dev
Goto Forum:
  


Current Time: Fri Oct 22 21:49:10 CEST 2021

Total time taken to generate the page: 0.02242 seconds