GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » Fairroot » External Packages » Compiling ROOT6 with gcc>5 (symbol '_ZN5cling10printValueEPKi' unresolved while linking [cling interface function]!)
Compiling ROOT6 with gcc>5 [message #19470] Tue, 23 August 2016 21:12 Go to next message
Yassid is currently offline  Yassid
Messages: 11
Registered: October 2015
occasional visitor
From: *dhcp.nscl.msu.edu
Hello:

This is a well known problem of ROOT which has to be compiled with -DCMAKE_CXX_FLAGS="-D_GLIBCXX_USE_CXX11_ABI=0"

My question is how to do that for FairSoft, I know that I should add the line -DCMAKE_CXX_FLAGS="-D_GLIBCXX_USE_CXX11_ABI=0" in the rootconfig.sh script but I just did not work, I still have the same problem inside ROOT:

IncrementalExecutor::executeFunction: symbol '_ZN5cling10printValueEPKi' unresolved while linking [cling interface function]!
You are probably missing the definition of cling::printValue(int const*)
Maybe you need to load the corresponding shared library?
(int) Error in ValuePrinter: missing output string.

Any thoughts?

Thank you very much in advance!
Yassid
Re: Compiling ROOT6 with gcc>5 [message #19471 is a reply to message #19470] Tue, 23 August 2016 21:33 Go to previous messageGo to next message
Mohammad Al-Turany is currently offline  Mohammad Al-Turany
Messages: 518
Registered: April 2004
Location: GSI, Germany
first-grade participant
From: *cern.ch
Hallo Yassid,

Did you remove the CMakeCache.txt and rootconfig.sh in "fairsoft/tools/root/build_for_fair/" before running the configure.sh again?

best,

Mohammad
Re: Compiling ROOT6 with gcc>5 [message #19472 is a reply to message #19470] Tue, 23 August 2016 23:44 Go to previous messageGo to next message
Yassid is currently offline  Yassid
Messages: 11
Registered: October 2015
occasional visitor
From: *dhcp.nscl.msu.edu
Hello:

Thanks for the reply. In principle yes, but I put it at the end without the \ on the previous condition and then It just ignored it.

Now I did it from the scratch and I get this error:

collect2: error: ld returned 1 exit status
net/netxng/CMakeFiles/NetxNG.dir/build.make:194: recipe for target 'lib/libNetxNG.so.6.06.02' failed
make[2]: *** [lib/libNetxNG.so.6.06.02] Error 1
CMakeFiles/Makefile2:16184: recipe for target 'net/netxng/CMakeFiles/NetxNG.dir/all' failed
make[1]: *** [net/netxng/CMakeFiles/NetxNG.dir/all] Error 2
Makefile:149: recipe for target 'all' failed
make: *** [all] Error 2
**** Checking libraries in /home/attpc/fair_install/FairSoftInst_may2016_ABI0/lib ****
*** ERROR: root could not be created.
create a symbolic linking for Vc library ....
libVc.a not found in lib dirctory
*** End installation of external packages with Errors***
attpc@control:~/fair_install/FairSoft_may2016$

I am using Ubuntu 16.04 with gcc 5.2.


This is how the rootconfig.sh looks like (at the bottom):
cmake ../ -Dsoversion=ON $PYTHONBUILD $XROOTD $ROOFIT \
-Dminuit2=ON -Dgdml=ON -Dxml=ON \
-Dbuiltin-ftgl=ON -Dbuiltin-glew=ON \
-Dbuiltin-freetype=ON $OPENGL \
-Dmysql=ON -Dpgsql=ON -Dasimage=ON \
-DPYTHIA6_DIR=$SIMPATH_INSTALL \
-DPYTHIA8_DIR=$SIMPATH_INSTALL \
-Dglobus=OFF \
-Dreflex=OFF \
-Dcintex=OFF \
$VC \
-Dhttp=ON \
-DGSL_DIR=$SIMPATH_INSTALL \
-DCMAKE_CXX_COMPILER=$CXX -DCMAKE_C_COMPILER=$CC \
-DCMAKE_CXX_FLAGS="-D_GLIBCXX_USE_CXX11_ABI=0" \
-DCMAKE_F_COMPILER=$FC $root_comp_flag $prefix_string \
$etc_string -Dgnuinstall=ON \
-DCMAKE_BUILD_TYPE=$BUILD_TYPE


It seems that the libNetxNG.so failed when compiling.

Thank you
Yassid
Re: Compiling ROOT6 with gcc>5 [message #19486 is a reply to message #19470] Sat, 27 August 2016 16:18 Go to previous message
Yassid is currently offline  Yassid
Messages: 11
Registered: October 2015
occasional visitor
From: *hsd1.mi.comcast.net
Hello again:

I have tried many options disabling many packacges such as pythia8 ( https://root.cern.ch/phpBB3/viewtopic.php?f=3&t=22150&p=97010#p9 7010), but I could not install it. I have to stick to the gcc 4.9 version but I would really like to use 6.1 to use openACC. I will wait for your feedback.

Thank you
Yassid
Previous Topic: Unpack boost package
Next Topic: problem with external packages
Goto Forum:
  


Current Time: Mon Nov 29 06:37:45 CET 2021

Total time taken to generate the page: 0.01940 seconds