GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » Fairroot » General Discussion » Problem in installing FairRoot version v-15.11
Problem in installing FairRoot version v-15.11 [message #19204] Tue, 12 April 2016 17:09 Go to next message
Elisabetta Prencipe (2) is currently offline  Elisabetta Prencipe (2)
Messages: 214
Registered: February 2013
first-grade participant
From: *ikp.kfa-juelich.de
Dear all,

since a few months I find serious prolbme in installing pandaroot releases. Today I tired again, from scratch, and following the suggested instructions:

1) external packages

>>>>>git clone https://github.com/FairRootGroup/FairSoft fairsoft_mar15
cd fairsoft_mar15/
git checkout -b mar15 mar15

./configure.sh

2) installing fairroot

>>>>>>>>>>export SIMPATH=/home/pandauser/fairsoft_mar15/buildFairSoft/
cd /home/pandauser/fairsoft_mar15/
git clone https://github.com/FairRootGroup/FairRoot.git
cd FairRoot
git checkout -b v-15.11 v-15.11
mkdir build
build
cmake -DCMAKE_INSTALL_PREFIX=/home/pandauser/fairsoft_mar15/buildFairRoot /home/pandauser/fairsoft_mar15/FairRoot

At this point, I get error.






-------------------------
-- C++11 support found.
-- Build CbmModule with Gdml support
-- C++11 support & boost libraries found. FairMQ will be built.
running /bin/chmod u+x /home/prencipe/panda/fairsoft_mar15/FairRoot/build/examples/advanced/Tut orial8/macros/unpack_mbs.sh 2>&1
-- Found Git: /usr/bin/git (found version "1.8.3.1")
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
ZMQ_INCLUDE_DIR (ADVANCED)
used as include directory in directory /home/prencipe/panda/fairsoft_mar15/FairRoot/parmq
used as include directory in directory /home/prencipe/panda/fairsoft_mar15/FairRoot/parmq
used as include directory in directory /home/prencipe/panda/fairsoft_mar15/FairRoot/fairmq
used as include directory in directory /home/prencipe/panda/fairsoft_mar15/FairRoot/fairmq
used as include directory in directory /home/prencipe/panda/fairsoft_mar15/FairRoot/fairmq
used as include directory in directory /home/prencipe/panda/fairsoft_mar15/FairRoot/fairmq
used as include directory in directory /home/prencipe/panda/fairsoft_mar15/FairRoot/fairmq
used as include directory in directory /home/prencipe/panda/fairsoft_mar15/FairRoot/fairmq
used as include directory in directory /home/prencipe/panda/fairsoft_mar15/FairRoot/fairmq
used as include directory in directory /home/prencipe/panda/fairsoft_mar15/FairRoot/fairmq/test
used as include directory in directory /home/prencipe/panda/fairsoft_mar15/FairRoot/fairmq/test
used as include directory in directory /home/prencipe/panda/fairsoft_mar15/FairRoot/fairmq/test
used as include directory in directory /home/prencipe/panda/fairsoft_mar15/FairRoot/fairmq/test
used as include directory in directory /home/prencipe/panda/fairsoft_mar15/FairRoot/fairmq/test
used as include directory in directory /home/prencipe/panda/fairsoft_mar15/FairRoot/fairmq/test
used as include directory in directory /home/prencipe/panda/fairsoft_mar15/FairRoot/fairmq/test
used as include directory in directory /home/prencipe/panda/fairsoft_mar15/FairRoot/fairmq/test
ZMQ_LIBRARY_SHARED (ADVANCED)
linked by target "FairMQ" in directory /home/prencipe/panda/fairsoft_mar15/FairRoot/fairmq

-- Configuring incomplete, errors occurred!
See also " /home/prencipe/panda/fairsoft_mar15/FairRoot/build/CMakeFiles/CMakeOutpu t.log ".
See also " /home/prencipe/panda/fairsoft_mar15/FairRoot/build/CMakeFiles/CMakeError .log ".


--------------------------

Last year I did not get such errors, but I had always troubles in pandaroot releases compilation. Now it is even worse. Any idea what is going wrong, and how to solve it?

Thanks, Elisabetta
Re: Problem in installing FairRoot version v-15.11 [message #19205 is a reply to message #19204] Tue, 12 April 2016 17:11 Go to previous messageGo to next message
Elisabetta Prencipe (2) is currently offline  Elisabetta Prencipe (2)
Messages: 214
Registered: February 2013
first-grade participant
From: *ikp.kfa-juelich.de
Ups...I forgot: my OsS is Fedora19.

Thanks in advance for your help,

Elisabetta
Re: Problem in installing FairRoot version v-15.11 [message #19206 is a reply to message #19204] Tue, 12 April 2016 18:34 Go to previous messageGo to next message
Florian Uhlig is currently offline  Florian Uhlig
Messages: 424
Registered: May 2007
first-grade participant
From: *gsi.de
Hi,

could you please attach the complete output of CMake and also the log file written during the installation of FairSoft.

Which compiler and ersion do you use?


Re: Problem in installing FairRoot version v-15.11 [message #19207 is a reply to message #19206] Wed, 13 April 2016 09:43 Go to previous messageGo to next message
Elisabetta Prencipe (2) is currently offline  Elisabetta Prencipe (2)
Messages: 214
Registered: February 2013
first-grade participant
From: *ikp.kfa-juelich.de
Hi all,

after some further debugging together with Tobias, this is the situation:

- with OS Suse and Fedora19, there are problems in installing FairRoot. Maybe even with otehr OS, but still did not checked.
- with Suse, following the instruction online ( https://panda-wiki.gsi.de/foswiki/bin/view/Computing/PandaRootInstallGit) it happens that some packages are missing: Pythia6, Xerces, geant3.... and I am still in the process to download manually and recompile....not finished yet.
- with Fedora19: an additional problem with dependencies was shown up. What I mean is that I started all installation process with:

yum install cmake cmake-data g++ gcc gfortran build-essential make patch sed \
libx11-dev libxft-dev libxext-dev libxpm-dev libxmu-dev libglu1-mesa-dev libgl1-mesa-dev \
curl bzip2 gzip unzip tar python-dev subversion git

This works for Suse; but for Fedora19 and other RedHat based systems, one needs the following:

yum install cmake gcc gcc-c++ gcc-gfortran make patch sed \
libX11-devel libXft-devel libXpm-devel libXext-devel \
libXmu-devel mesa-libGLU-devel mesa-libGL-devel ncurses-devel \
curl bzip2 libbz2-dev gzip unzip tar expat-devel \
subversion git flex bison imake redhat-lsb-core \
python-devel libxml2-devel wget openssl-devel curl-devel \
automake autoconf libtool

with Fedora 22 /23, it is even a bit more complicated. Please, have a look here: https://github.com/FairRootGroup/FairSoft/blob/master/DEPENDENCIES

It was not like so in January 2016. Something changed.
Indeed, after solving this, the installation does not go smooth at all. Some packages are not automatically downloaded. I am wondering what changed in the past 2 months, or if it is only a problem of temporary inaccessible libraries from Root, as for me in January2016 everything was basically working. Since yesterday or sooner, it is not possible to install FairRoot following the standard tutorial.

Best regards, Elisabetta
Re: Problem in installing FairRoot version v-15.11 [message #19208 is a reply to message #19207] Wed, 13 April 2016 09:47 Go to previous messageGo to next message
Elisabetta Prencipe (2) is currently offline  Elisabetta Prencipe (2)
Messages: 214
Registered: February 2013
first-grade participant
From: *ikp.kfa-juelich.de
Hi again,

just to make it clear. The last message I to today is:

--------------------------------
[...]

Libraries done.
**** Checking libraries in /home/prencipe/panda/fairsoft_mar15/buildFairSoft/lib ****
*** Pluto compiled successfully ***
*** Downloading geant3 sources ***
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- 0:02:07 --:--:-- 0curl: (7) Failed to connect to 2001:1458:201:45::100:b: Network is unreachable
*** Unpacking geant321+_vmc.1.15a.tar.gz ..............
--E-- Cannot unpack package geant3


So, now I am trying to download manually geant321+_vmc.1.15a.tar.gz. I hope it is the last missing package.... this happens with different OS since yesterday. It is not a 'Fedora19' problem.

cheers, Elisabetta
Re: Problem in installing FairRoot version v-15.11 [message #19210 is a reply to message #19208] Wed, 13 April 2016 10:48 Go to previous messageGo to next message
Florian Uhlig is currently offline  Florian Uhlig
Messages: 424
Registered: May 2007
first-grade participant
From: *gsi.de
Since I am not able to access the installation instructions I am guessing that you are using the mar15 release of FairSoft.

The problem with pythia6 and now geant3 is that the root group switched off their ftp server some days ago. Do to this the needed source packages can't be downloaded. Yesterday I fixed the download location for pythia6 but overlooked that geant3 is downloaded from the same server (with FairSoft release mar15). This I fixed today, so please update to the latest patch release of mar15

git checkout -b tag_mar15p6 mar15p6

After the update you can simply rerun the configure script.

Could someone also update the installation instruction and change the FairSoft version to the latest patch release.
Re: Problem in installing FairRoot version v-15.11 [message #19211 is a reply to message #19210] Wed, 13 April 2016 10:50 Go to previous message
Elisabetta Prencipe (2) is currently offline  Elisabetta Prencipe (2)
Messages: 214
Registered: February 2013
first-grade participant
From: *ikp.kfa-juelich.de
Thanks, Florian!

I just finished my installation right now, after downloading manually the missing packages, and it looks working.
Maybe I can try with your new fix and see if it works.

And yes, I was trying to install mar15, with some problems.


Best regards, Elisabetta
Previous Topic: Using zlib
Next Topic: Problem compiling master FAIRRoot
Goto Forum:
  


Current Time: Sat Oct 16 14:54:44 CEST 2021

Total time taken to generate the page: 0.02065 seconds