GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » General » Warning about Ubuntu distributions
Warning about Ubuntu distributions [message #18961] Tue, 02 February 2016 00:34
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *to.infn.it
Dear all,
this is a warning for all the people using an Ubuntu (or derived) distribution.

Ubuntu provides two different kind of distributions, the LTS release and the non-LTS. LTS means Long Time Support, and it is supported for two years, while the non-LTS releases have a life of 9 months. This means that afterwards the releases are not maintained anymore, and you are not able to update the distribution or install new packages.

As an example, one year ago there were Ubuntu 14.04 LTS and Ubuntu 14.10. Now there is still 14.04 LTS but 14.10 is not maintained anymore, there is 15.10, you are not able to do a apt-get install in your 14.10, while the system continues to work with 14.04 LTS. Next LTS will be 16.04 LTS.

For obvious reasons, we strongly suggest Ubuntu users to install LTS releases, and we suggest also Ubuntu developers to install LTS releases.
If you install non-LTS distributions, be prepared in less than one year to install new OS distribution, and compile again FairSoft, FairRoot and PandaRoot.

In short terms, if in a short time we will need to add additional packages to the requirements due to new software, you will have to change your non-LTS distribution (as I have to do know).

Forewarned is forearmed.
Previous Topic: Rules for conferences
Next Topic: Centralized data producrtion
Goto Forum:
  


Current Time: Sat Jun 25 07:26:54 CEST 2022

Total time taken to generate the page: 0.00741 seconds