GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » [FIXED] Cannot run sample macros (PANDA ROOT )
[FIXED] Cannot run sample macros [message #18606] Fri, 30 October 2015 16:31 Go to next message
mckunkel is currently offline  mckunkel
Messages: 11
Registered: October 2015
occasional visitor
From: *ikp.kfa-juelich.de
Greetings,

I just performed a fresh install of FairSoft, FairRoot and PandaRoot.

When I try the example macros to ensure PandaRoot, I receive an issue with reco_complete.C after running sim_complete.C and digi_complete.C


MZLINK. Initialize Link Area /GCSLNK/ for Store 0 NL/NS= 100 100
-I- G3Config: Geant3 with TGeo has been created for Geane.
Warning: Automatic variable noprnt is allocated /Users/michaelkunkel/WORK/PANDA/PANDAROOT/SOURCE/gconfig/Geane.C:26:

*** Break *** segmentation violation
-I- Geane.C: NOPRNT flag set to Generating stack trace...
An admin user name and password is required to enter Developer Mode.


[Updated on: Wed, 03 February 2016 23:37] by Moderator

Report message to a moderator

Re: Cannot run sample macros [message #18607 is a reply to message #18606] Fri, 30 October 2015 17:15 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *to.infn.it
Could you please tell which is your OS version and which XCode you are using?

And can you copy the full log, from the beginning of the macro unti the error messages? lldb could help to undertsand what went wrong.
Re: Cannot run sample macros [message #18608 is a reply to message #18607] Fri, 30 October 2015 17:20 Go to previous messageGo to next message
mckunkel is currently offline  mckunkel
Messages: 11
Registered: October 2015
occasional visitor
From: *ikp.kfa-juelich.de
Greetings,

I am using Mac OSX 10.10.5, XCode 7.1.
Attached is the output of the reco_complete.C
  • Attachment: log.log
    (Size: 11.30KB, Downloaded 187 times)
Re: Cannot run sample macros [message #18609 is a reply to message #18608] Fri, 30 October 2015 17:28 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *to.infn.it
Are you using FairSoft mar15? Since the root version should be the 5.34/25 and not the 5.34/32 that you have.
Re: Cannot run sample macros [message #18610 is a reply to message #18609] Fri, 30 October 2015 17:31 Go to previous messageGo to next message
mckunkel is currently offline  mckunkel
Messages: 11
Registered: October 2015
occasional visitor
From: *ikp.kfa-juelich.de
Greetings,

I had to use the dev branch because the mar15, mar15p1 and mar15p2 branches of FairSoft did not build Geeant4 properly.

Here is the issue I posted on the FairSoft issue page on GitHub

https://github.com/FairRootGroup/FairSoft/issues/29
Re: Cannot run sample macros [message #18611 is a reply to message #18610] Fri, 30 October 2015 17:34 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *to.infn.it
The dev branch is untested for PandaRoot, then I am not sure on what is wrong in Geane. Which FairRoot version? Also dev?
Re: Cannot run sample macros [message #18612 is a reply to message #18606] Fri, 30 October 2015 17:37 Go to previous messageGo to next message
mckunkel is currently offline  mckunkel
Messages: 11
Registered: October 2015
occasional visitor
From: *ikp.kfa-juelich.de
Yes, I am using dev for both FairSoft and FairRoot
Re: Cannot run sample macros [message #18613 is a reply to message #18612] Fri, 30 October 2015 17:41 Go to previous messageGo to next message
Radoslaw Karabowicz is currently offline  Radoslaw Karabowicz
Messages: 108
Registered: June 2004
Location: GSI
continuous participant
From: *dip0.t-ipconnect.de
As a fast solution, please comment out the following lines:

if(gROOT->GetVersionCode() >= 334848)
{
Ertrio1_t *fErtrio1 = gMC3->fErtrio1;
fErtrio1->noprnt = 1;
cout << "-I- Geane.C: NOPRNT flag set to " << fErtrio1->noprnt << endl;
if(fErtrio1->noprnt == 1) {
cout << "-I- Geane.C: IERR flags are not printed. If you want to switch them on, please set fErtrio1->noprnt = 0 in Geane.C" << endl;
}
}

in your gconfig/Geane.C

yours
radek
Re: Cannot run sample macros [message #18614 is a reply to message #18606] Fri, 30 October 2015 17:48 Go to previous messageGo to next message
mckunkel is currently offline  mckunkel
Messages: 11
Registered: October 2015
occasional visitor
From: *ikp.kfa-juelich.de
Thank you,

Commenting out those lines allowed the program to run.
The complete test chain is complete.
Re: Cannot run sample macros [message #18635 is a reply to message #18613] Tue, 03 November 2015 10:23 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *netrun.cytanet.com.cy
Why these calls are not present anymore in the dev FairSoft?
Re: Cannot run sample macros [message #18683 is a reply to message #18635] Wed, 11 November 2015 11:50 Go to previous messageGo to next message
Radoslaw Karabowicz is currently offline  Radoslaw Karabowicz
Messages: 108
Registered: June 2004
Location: GSI
continuous participant
From: *gsi.de
Found the damn problem finally.

It seems that quite recently (between FairSoft mar15 and jul15)
the file transport/geant3/TGeant3/geant3LinkDef.h
was changed and line:
#pragma link C++ class Ertrio1_t+;
was commented out with the following comment:
// Unused class rule
// (generate warning with Root6 cling)

Unfortunately in Panda we use the struct in the root-loaded macro.

I have changed the file and added:

#pragma link C++ struct Ertrio_t+;
#pragma link C++ struct Ertrio1_t+;

did (in Fairsoft):

./make_clean.sh geant3 all
./configure.sh

After this the setting of the noprnt works!
I have also checked root6.
Setting the flag works without any changes to the linkdef.h
After putting of the lines it still compiles (at least on my mac).

yours
radek
Re: Cannot run sample macros [message #18684 is a reply to message #18683] Thu, 12 November 2015 23:50 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *ip40.fastwebnet.it
Thanks Radek,
but do you think that line will be rdecommented in some next version of FairSoft?
Re: Cannot run sample macros [message #18685 is a reply to message #18684] Fri, 13 November 2015 08:51 Go to previous messageGo to next message
Radoslaw Karabowicz is currently offline  Radoslaw Karabowicz
Messages: 108
Registered: June 2004
Location: GSI
continuous participant
From: *gsi.de
Yes, of course! I have already contacted the Geant3 team to have it fixed.
Re: Cannot run sample macros [message #18688 is a reply to message #18685] Fri, 13 November 2015 15:17 Go to previous message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: 93.49.204*
If I remember correctly, the flag was introduced under Lia's request in order to have the possibility to switch OFF geane warnings which were dominating our logs at that time.
Previous Topic: [NOTABUG] Linking to libField.so causes seg violation
Next Topic: [FIXED] genfit2 update - bugs(?)
Goto Forum:
  


Current Time: Sat Apr 13 13:41:33 CEST 2024

Total time taken to generate the page: 0.01232 seconds