GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » LVUG » LVUG - Technische Fragen » Set Cell Value invoke node on Table crashes LabVIEW
icon9.gif  Set Cell Value invoke node on Table crashes LabVIEW [message #1339] Mon, 31 January 2005 17:04 Go to next message
Manfred Leffler is currently offline  Manfred Leffler
Messages: 28
Registered: November 2004
Location: Norddeutschland
continuous participant
From: 195.243.194*
Hallo,

Offensichtlich habe ich die Invoke Node Methode noch nicht so ganz gerafft.
Werte werden beim Start des Programms sauber in die Tabelle geschrieben.
Wenn jedoch Änderungen an Controls getätigt werden bricht LabVIEW (7.0 und 7.1) komplett ab.

Bitte schaut mal auf das VI. Seit 10 Jahren LabVIEW stehe ich zum ersten Mal vor der Wand. Rolling Eyes

Grüsse aus dem Norden

Manfred
Re: Set Cell Value invoke node on Table crashes LabVIEW [message #1341 is a reply to message #1339] Mon, 31 January 2005 18:47 Go to previous messageGo to next message
Franz Josef Ahlers is currently offline  Franz Josef Ahlers
Messages: 22
Registered: January 2004
occasional visitor
From: *dip0.t-ipconnect.de
Ich kann das Verhalten bestätigen.

Riecht zunächst nach einem bug, aber:
die variable table ist ein 2D array of string. Ein Wert wird table aber nie zugewiesen, nur am Anfang wird ReInit to Default aufgerufen

In der Schleife selbst gibt es keine Wertzuweisungen an table, weder direkt, noch über eine lokale Variable, noch über den property node 'Value'. Stattdessen wird eine Zelle direkt beschrieben. Nun steht zwar im manual nicht explizit, dass man das nicht darf, aber wer weiß...

Ich habe jedenfalls mal folgendes probiert: (im Edit mode) die 3. Spalte der n. Reihe von table mit einem wert belegt, dadurch erhalten alle zellen bis dahin einen Leerstring zugewiesen. Dann diesen Wert für table als Default deklariert. Nun läuft das VI anscheinend sauber, aber nur bis zur n. Zeile. Dann krachts... Spricht sehr dafür, dass es ein (LV internes) memory alloc problem ist.

Zu guter letzt: Warum überhaupt so kompliziert?? Warum schreibst Du nicht direkt in den Indikator wie im angehängten Beispiel LV Crash 03_.vi?


Franz
icon14.gif  Re: Set Cell Value invoke node on Table crashes LabVIEW [message #1343 is a reply to message #1341] Tue, 01 February 2005 09:16 Go to previous messageGo to next message
Manfred Leffler is currently offline  Manfred Leffler
Messages: 28
Registered: November 2004
Location: Norddeutschland
continuous participant
From: 195.243.194*
Franz,

vielen Dank für die Bestätigung des Totalabsturzes vom VI. Ich habe schon die unmöglichsten Dinge vermutet.
Die ganze Tabelle zu beschreiben (wie in dem Beispiel LV Crash 01_.vi gezeigt) war meine erste Lösung.
Dann wird aber immer das komplette Array neu beschrieben.
Ich habe mich dann gefragt was geschieht z.B. nach 24*1800*3=129600 Strings.
Set Cell Value Invoke Node schien mir die elegantere Lösung.
Ich werde jetzt mal testen wie die Performance nach 24 simulierten Stunden mit dem kompletten Array ist.

Nochmals herzlichen Dank für die Unterstützung

Manfred
Re: Set Cell Value invoke node on Table crashes LabVIEW [message #1361 is a reply to message #1343] Mon, 07 February 2005 10:02 Go to previous messageGo to next message
Franz Doepp is currently offline  Franz Doepp
Messages: 3
Registered: January 2005
Location: Darmstadt
occasional visitor
From: 195.63.185*
Hallo Manfred,

bei mir läuft Dein Original-VI ohne Probleme (Labview 7.0Express Student Edition)

Weiss nicht, ob es Dich weiterbringt ...


Beste Grüße aus Darmstadt,

Franz
Re: Set Cell Value invoke node on Table crashes LabVIEW [message #1362 is a reply to message #1361] Mon, 07 February 2005 13:04 Go to previous messageGo to next message
Manfred Leffler is currently offline  Manfred Leffler
Messages: 28
Registered: November 2004
Location: Norddeutschland
continuous participant
From: 195.243.194*
Hallo Franz D.,

vielen Dank für die Rückmeldung.
Ich habe einen ServiceRequest bei NI laufen. NI Deutschland und USA können den Crash auch nicht reproduzieren.
Seltsam Franz Josef konnte den Fehler reproduzieren.
Die Antwort aus den USA lautet:
"In regards to your question, I was unable to reproduce the crash on my
computer as well. I have investigated into the issue a little more, and
there were some issues known with the Set Cell Value property.
1. The error might be due to the fact that the table needs to have
its cells initialized first before they can be set. It could be that as
the program is running for an extended period of time, LabVIEW is having
difficulty allocating the necessary memory for the additional table cell.
How long is your customer running the program before it returns the error?
If it's for some time, the reason for the crash is that LabVIEW is
running out of available memory on the computer to allocate for the table.


2. Also, there was a CAR in LabVIEW 6.1 where setting values of the
table was giving errors when the table was an indicator. Change the table
to a control instead and see if this changes anything."


Kann mich jetzt kurzfristig nicht mit der Sache beschäftigen. Jede Rückmeldung aus dem Forum ist weiterhin willkommen.
Spätestens wenn die Sache gelöst ist werde ich das Ergebnis hier posten.

Gruss aus dem Norden

Manfred


[Updated on: Mon, 07 February 2005 13:06]

Report message to a moderator

Re: Set Cell Value invoke node on Table crashes LabVIEW [message #1364 is a reply to message #1362] Mon, 07 February 2005 21:38 Go to previous message
Franz Josef Ahlers is currently offline  Franz Josef Ahlers
Messages: 22
Registered: January 2004
occasional visitor
From: *dip0.t-ipconnect.de
Hallo!

Ich habe die VI nochmals durchgecheckt: war zunächst verblüfft, sie lief ne Weile ohne crash (ca. 5 bis 10 mal gestartet, zwischenddurch auch mal das timing im block diagramm beschleunigt, um die table schneller mit Werten zu füllen).

Irgendwann hat es aber dann doch gecrasht, man muß anscheinend "Geduld" haben. Hat es aber erstmal gecrasht, dann passiert es reproduzierbar immer wieder. Dabei ist es dann egal, ob die table control oder indicator ist. Ach ja: es scheint nicht zu crashen, wenn man die verschiedenen enum Felder mit den up-down Pfeilen steuert, man muss direkt die enum anwählen. Ist schon arg merkwüdig.

Ich denke, die Antwort von NI ("The error might be due to the fact that the table needs to have its cells initialized first before they can be set"), die ja meiner ursprünglichen Vermutung entspricht, trifft den Kern.


Franz
Previous Topic: Samplerate-Buffersize
Next Topic: LabVIEW - CAN Bus - CCP auf Vector CAN Karte
Goto Forum:
  


Current Time: Wed Apr 17 12:16:36 CEST 2024

Total time taken to generate the page: 0.00942 seconds