GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » [FIXED] mar15 - problem with intallation
[FIXED] mar15 - problem with intallation [message #18586] Tue, 27 October 2015 17:09 Go to next message
Elisabetta Prencipe (2) is currently offline  Elisabetta Prencipe (2)
Messages: 214
Registered: February 2013
first-grade participant
From: *ikp.kfa-juelich.de
Hello Stefano,

I am trying to install mar15, unsuccessfully.

Now finally I got installed the fairroot packages as suggested in the wiki. However, when I arrived at the point to install and compile the release on my pc (o.s. Fedora19), the following error occurs:

****************
cmake ../mar15/
-- NOT Found FAIRBASE
CMake Warning at CMakeLists.txt:60 (find_package):
By not providing "FindFairRoot.cmake" in CMAKE_MODULE_PATH this project has
asked CMake to find a package configuration file provided by "FairRoot",
but CMake did not find one.

Could not find a package configuration file provided by "FairRoot" with any
of the following names:

FairRootConfig.cmake
fairroot-config.cmake

Add the installation prefix of "FairRoot" to CMAKE_PREFIX_PATH or set
"FairRoot_DIR" to a directory containing one of the above files. If
"FairRoot" provides a separate development package or SDK, be sure it has
been installed.

*********
It is the third time this week that I try to uninstall and install again those packages.

Could you please say what am I missing here? I am following the instruction at https://panda-wiki.gsi.de/foswiki/bin/view/Computing/PandaRootInstallGit

It does not work out for me.

Best regards, Elisabetta

[Updated on: Wed, 28 October 2015 10:16] by Moderator

Report message to a moderator

Re: mar15 - problem with intallation [message #18589 is a reply to message #18586] Tue, 27 October 2015 18:40 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *to.infn.it
Hi,
could you pleae type the output of the following commands?

echo $SIMPATH
ls $SIMPATH
echo $FAIRROOTPATH
ls $FAIRROOTPATH

Re: mar15 - problem with intallation [message #18593 is a reply to message #18589] Wed, 28 October 2015 10:10 Go to previous message
Elisabetta Prencipe (2) is currently offline  Elisabetta Prencipe (2)
Messages: 214
Registered: February 2013
first-grade participant
From: *ikp.kfa-juelich.de
Hello Stefano,

echo $SIMPATH
/home/prencipe/panda/fairsoft_mar15/buildFairSoft/
[prencipe@pool-254-22-zam037 buildPanda]$ ls $SIMPATH
bin include lib lib64 share



[prencipe@pool-254-22-zam037 buildPanda]$ echo $FAIRROOTPATH
/home/prencipe/panda/fairsoft_mar15/buildFairRoot/
[prencipe@pool-254-22-zam037 buildPanda]$ ls $FAIRROOTPATH
bin include lib share


Today I removed everything again, and re-start all process from scratch.

I do cmake with the option:

cmake -DUSE_DIFFERENT_COMPILER=TRUE ../../mar15


I see lots of warnings [...][-Wshadow], especially wit hthe packages related to Lumi* and boost.

But in the end today I succeeded. With the older releases (=< oct14) I've never found so much troubles. It is the second time that I try to install mar15 (or trunk revisions) in the last month, and 2 times I got problems. Something is weird.... anyway, today I got it running. So, now I can spend some time in genfit2 debugging.

My best regards, and thanks,
Elisabetta
Previous Topic: [FIXED]PandaRoot make error
Next Topic: [NOTABUG] Linking to libField.so causes seg violation
Goto Forum:
  


Current Time: Thu Dec 09 04:59:29 CET 2021

Total time taken to generate the page: 0.02207 seconds