GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » [FIXED] Problems with sim macro
[FIXED] Problems with sim macro [message #18542] Tue, 06 October 2015 11:22 Go to next message
Jennifer Pütz is currently offline  Jennifer Pütz
Messages: 47
Registered: April 2015
Location: FZ Juelich
continuous participant
From: *ikp.kfa-juelich.de
Hi all,

I have a problem with the "standard" sim macro.
I run a test simulation for pbar p -> Xi(1820)+ Xi- with 1000 events and a beam momentum of 4.6 GeV/c .
When I look into the macro output sim_complete.root there are two cbmsim branches named cbmsim;1 and cbmsim;2. The number of entries in cbmsim;1 is smaller than in cbmsim;2. And the number of generated particles with motherID==-1 is not matching for cbmsim;1. (For cbmsim;2 everything seems to be fine.)
The problem is that the standard pid macro seems to use cbmsim;1.

If I reduce the number of events to e.g. 500, there is only one cbmsim branch with the correct number of generated particles in the output file.
Can anyone help me with this problem?
I attached the sim macro, my .dec-file and a modified evt.pdl which contains the added Xi(1820)+ particle.

Cheers
Jenny

---------------------------------------
I'm using:

PandaRoot: trunk rev. 28555
Fairsoft: mar15
FairRoot: master

[Updated on: Mon, 12 October 2015 16:33] by Moderator

Report message to a moderator

Re: Problems with sim macro [message #18544 is a reply to message #18542] Tue, 06 October 2015 12:38 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *to.infn.it
Quote:
The problem is that the standard pid macro seems to use cbmsim;1.


How did you see this? if you do cbmsim->GetEntries(), how many events do you have after sim and after pid macro?
Re: Problems with sim macro [message #18545 is a reply to message #18542] Tue, 06 October 2015 13:10 Go to previous messageGo to next message
Klaus Götzen is currently offline  Klaus Götzen
Messages: 293
Registered: June 2006
Location: GSI
first-grade participant
From: *gsi.de
Hi Jenny,


you might take a look here: https://root.cern.ch/root/roottalk/roottalk11/0963.html Doesn't seem to be a problem.


Best,
Klaus
Re: Problems with sim macro [message #18546 is a reply to message #18542] Tue, 06 October 2015 13:35 Go to previous message
Jennifer Pütz is currently offline  Jennifer Pütz
Messages: 47
Registered: April 2015
Location: FZ Juelich
continuous participant
From: *ikp.kfa-juelich.de
Hi Stefano, hi Klaus,

thank you for the quick answer.
After I did the checks Stefano sugessted I realized that I mixed up something in my files. Sorry for this.
I compared again the number of particles from the sim macro with the number of MC particles I get with my analysis macro from the pid-file. And now the numbers are matching.

Cheers,

Jenny

[Updated on: Tue, 06 October 2015 13:36]

Report message to a moderator

Previous Topic: [FIXED] Svn connectivity to sourceforge
Next Topic: [FIXED]PandaRoot make error
Goto Forum:
  


Current Time: Wed Dec 08 11:06:14 CET 2021

Total time taken to generate the page: 0.02079 seconds