GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » Fairroot » External Packages » error @ FairSoft installation
error @ FairSoft installation [message #18307] Mon, 15 June 2015 16:20 Go to next message
Simon Reiter is currently offline  Simon Reiter
Messages: 44
Registered: May 2013
continuous participant
From: *wlan.uni-giessen.de
Hi everybody,

I tried to install a newer version of pandaroot and had problems at early steps. FairSoft installation finishes with errors.. The last (i guess relevant lines) of the log are saved in the log file.
  • Attachment: log.txt
    (Size: 11.88KB, Downloaded 307 times)
Re: error @ FairSoft installation [message #18308 is a reply to message #18307] Tue, 16 June 2015 11:51 Go to previous messageGo to next message
Stefan Pflueger is currently offline  Stefan Pflueger
Messages: 99
Registered: February 2012
continuous participant
From: *wlan.cwi.nl
Hi Simon,

I would say your Millipede installation most likely fails, because your gfortran compiler does not know the -cpp option.
https://gcc.gnu.org/wiki/GFortran/News says that it was introduced in version 4.4 of gcc (that also would explain why there are some strange gcc44 calls in the log file, that are unknown commands on your machine). So a long story short I would say your gfortran version is below 4.4. If so, try updating it to 4.4+ and rerun the installation.

Cheers,

Stefan
Re: error @ FairSoft installation [message #18309 is a reply to message #18308] Tue, 16 June 2015 12:06 Go to previous message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *to.infn.it
In the FairRoot page it is written to use gfortan from 4.9.
Previous Topic: Problem in installation of fairsoft on ubuntu 14.10
Next Topic: Compiling FairSoft/ROOT with FFTW3 and MINUIT2
Goto Forum:
  


Current Time: Sun Oct 24 18:49:35 CEST 2021

Total time taken to generate the page: 0.01972 seconds