GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » [FIXED] Bug of XCode 6.3 harming geant4 compilation
icon9.gif  [FIXED] Bug of XCode 6.3 harming geant4 compilation [message #18149] Tue, 21 April 2015 12:24 Go to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *to.infn.it
Dear Mac users,
it seems the recent XCode release 6.3 has a bug inside, and if you upgrade your XCode you won't be able to compile geant4. Please continue to use 6.2 before a fix is released by Apple.

[Updated on: Mon, 27 April 2015 18:03]

Report message to a moderator

Re: Bug of XCode 6.3 harming geant4 compilation [message #18166 is a reply to message #18149] Thu, 23 April 2015 14:15 Go to previous messageGo to next message
Florian Uhlig is currently offline  Florian Uhlig
Messages: 424
Registered: May 2007
first-grade participant
From: 140.181.11*
Hi Stefano,

actually the problem is not really XCode but the Geant4 build system, which is fixed in the fairsoft release mar15p1.

There have been problems with XCode 6.3 which are meanwhile fixed in an update which can be installed via the Apple App Store.
There was a severe problem with the Command Line Tools (CLT) where at least one include file was missing. Also for this package there is an update available in the App Store.

To summarize, it is now save to update XCode and the CLT when using the patch release mar15p1.

Ciao

Florian
Re: Bug of XCode 6.3 harming geant4 compilation [message #18167 is a reply to message #18166] Thu, 23 April 2015 14:17 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *to.infn.it
Many thanks, I will try right now.
Re: Bug of XCode 6.3 harming geant4 compilation [message #18168 is a reply to message #18167] Thu, 23 April 2015 17:48 Go to previous message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *to.infn.it
Hi,
I tried the newest stuff, Xcode 6.3.1 and mar15p1, and everything works. Thanks
Previous Topic: [FIXED] PandaRoot rev 27292 fails to compile [PID]
Next Topic: [FIXED] error in geant4 installation
Goto Forum:
  


Current Time: Sat Jan 28 18:53:08 CET 2023

Total time taken to generate the page: 0.00960 seconds