GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » AGATA » AGATA - AGAPRO » Install (Place to discuss installation/compilation problems)
Install [message #17718] Thu, 08 January 2015 17:54 Go to next message
stezow is currently offline  stezow
Messages: 13
Registered: January 2015
occasional visitor
From: *in2p3.fr
The AGAPRO package contains the c++ actors [ex PSA, Tracking] processing the AGATA Data Flow
Online in NARVAL
or
Offline in emulators

Re: Install [message #18145 is a reply to message #17718] Mon, 20 April 2015 21:39 Go to previous messageGo to next message
Angel is currently offline  Angel
Messages: 6
Registered: March 2015
occasional visitor
From: *ikp.physik.tu-darmstadt.de
Hello Olivier,

Recently I run the folowing commands to recompile the agapro:
python scripts/AgataSoftware.py --agapro= clean
python scripts/AgataSoftware.py --agapro= config
python scripts/AgataSoftware.py --agapro= compile

After the last one I've got an error:
...
CMake Error at /usr/share/cmake-2.8/Modules/FindSubversion.cmake:83 (message):
Command "/usr/bin/svn info
/agata/AgataSoftware/agapro" failed with output:

svn: E155036: Please see the 'svn upgrade' command
...

The svn version I am using is 1.7.9 (r1462340). Then i run
the command 'svn upgrade' in agapro folder. After that I repeated
the previous commands. And again the compilation process failed with error:
...
/agata/AgataSoftware/agapro/common/cycleServer.cpp:67:39: error: 'unlink' was not declared in this scope
int done = unlink(comFile.c_str());
^
make[2]: *** [common/CMakeFiles/AgaProCommon.dir/cycleServer.cpp.o] Error 1
make[1]: *** [common/CMakeFiles/AgaProCommon.dir/all] Error 2
make: *** [all] Error 2
...

With the previous version of the 'svn' program (1.6) there was no such error.
Also in compiling of the femul again with the same python script:
python scripts/AgataSoftware.py --femul= compile

I've got the following error:
...
/agata/AgataSoftware/LNL/../include/adetParams.h:38:18: error: expected unqualified-id before numeric constant
static const int NCC = 2; // number of core signals
^
make[2]: *** [CMakeFiles/femul.dir/femul/femul.cpp.o] Error 1
make[1]: *** [CMakeFiles/femul.dir/all] Error 2
make: *** [all] Error 2
...

The detiled view of the error messages you can find in the attached file error-log.txt
Could you give any suggestions how to fix these errors?
Re: Install [message #18177 is a reply to message #18145] Mon, 27 April 2015 14:38 Go to previous messageGo to next message
stezow is currently offline  stezow
Messages: 13
Registered: January 2015
occasional visitor
From: *in2p3.fr
Hi Angel,

I cannot see how updating svn could affect the compilation configuration/compilation/installation of AGAPRO ...

Could you try to install completely from scratch just to see what is going on ?

Best regards
Olivier
Re: Install [message #18184 is a reply to message #18177] Wed, 29 April 2015 14:44 Go to previous messageGo to next message
Angel is currently offline  Angel
Messages: 6
Registered: March 2015
occasional visitor
From: *gsi.de
Hello Olivier,
I did it from scratch and everything is O.K. It is working normaly even with multi-threads support enabled.
I still have no explanation why it didn't run normaly before.

Angel
icon9.gif  Problem with getting agapro from the Legnaro svn repo [message #19278 is a reply to message #17718] Tue, 24 May 2016 18:44 Go to previous messageGo to next message
cstahl is currently offline  cstahl
Messages: 3
Registered: July 2014
Location: IKP, TU Darmstadt
occasional visitor
From: *ikp.physik.tu-darmstadt.de
Dear colleagues,

I tried to install the agapro package following the cookbook which I downloaded from atrium
(atrium.in2p3.fr).

Retrieving and compiling adf (by the script call "python scripts/AgataSoftware.py --adf= all") was working without problem.
However, retrieving agapro failed. The output was:
python scripts/AgataSoftware.py --agapro= all
[AgataSoftware] Some global definitions as read from envronment ...
 [?]==> CMAKE_BUILD_TYPE not found in env, keep default
 [+]==> CMAKE_BUILD_TYPE Release
 [?]==> CMAKE_INSTALL_PREFIX not found in env, keep default
 [+]==> CMAKE_INSTALL_PREFIX /media/Daten/Femul_Test/AgataSoftware
 [?]==> CMAKE_OPTIONS not found in env, keep default
 [+]==> CMAKE_OPTIONS 
 [?]==> REPO_REV not found in env, keep default
 [+]==> REPO_REV 
[AgataSoftware] ... Some global definitions as read from envronment
('[load] ==> Start loading the package ', '--agapro')
(' All programs found ', ['svn', 'cmake'])
 svn co  svn://gamma01.lnl.infn.it/agata/trunk/narval_emulator/ ./agapro
svn: E000110: Unable to connect to a repository at URL 'svn://gamma01.lnl.infn.it/agata/trunk/narval_emulator'
svn: E000110: Kann nicht mit Host »gamma01.lnl.infn.it« verbinden: Die Wartezeit für die Verbindung ist abgelaufen
[load] DONE 
('[conf] ==> Start configuring the package ', '--agapro')
 *** *** CMakeLists.txt NOT FOUND, agapro does not exist *** 
[conf] *** Something wrong @ configuring *** --agapro

(The german error message says unable to connect to host gamma01.lnl.infn.it, connection time expired)
Do I interpret it correctly that the svn repo at Legnaro is not available? Am I using outdated versions of the scripts?
I'm using svn version 1.8.10 on an x86_64 debian linux machine.

thank you for any help,


Christian

[Updated on: Tue, 24 May 2016 18:48]

Report message to a moderator

Re: Problem with getting agapro from the Legnaro svn repo [message #19281 is a reply to message #19278] Wed, 25 May 2016 10:05 Go to previous messageGo to next message
Damian Ralet
Messages: 35
Registered: July 2014
Location: Darmstadt
continuous participant
From: *in2p3.fr
Hi Christian,

It seems to me that the lnl repository is indeed down.
I cross check with my version of: scripts/AgataSoftware.py and I have the same snv repository.
I used this version a few month ago for a fresh installation, so I think they should still be valid.

Have you contacted someone from LNL? THis might just be a gateway issue.

Cheers,
Damian
Re: Problem with getting agapro from the Legnaro svn repo [message #19283 is a reply to message #19281] Wed, 25 May 2016 11:08 Go to previous messageGo to next message
stezow is currently offline  stezow
Messages: 13
Registered: January 2015
occasional visitor
From: 134.158.129*

Hi Christian,

As Damian, I've got the same issue which is indeed due to the svn server @ legnaro not responding anymore.
I've sent a email to Dino to report the problem and I am waiting for the answer .

Cheers
Olivier
Re: Problem with getting agapro from the Legnaro svn repo [message #19289 is a reply to message #19283] Wed, 25 May 2016 16:16 Go to previous messageGo to next message
cstahl is currently offline  cstahl
Messages: 3
Registered: July 2014
Location: IKP, TU Darmstadt
occasional visitor
From: *ikp.physik.tu-darmstadt.de
Dear Olivier and Damian,

thank you for the fast reaction and your actions!
So let's wait what Dino says.. Smile


Cheers,


Christian
Re: Problem with getting agapro from the Legnaro svn repo [message #19291 is a reply to message #19289] Thu, 26 May 2016 10:42 Go to previous messageGo to next message
stezow is currently offline  stezow
Messages: 13
Registered: January 2015
occasional visitor
From: 134.158.129*

Dear Christian,

As a matter of fact the disk at Legnaro hosted the svn server has crashed.
They are tried to recovered it. I will post a ticket once once I have some news about it.

Cheers
Olivier
Re: Problem with getting agapro from the Legnaro svn repo [message #19348 is a reply to message #19291] Tue, 28 June 2016 08:41 Go to previous messageGo to next message
cstahl is currently offline  cstahl
Messages: 3
Registered: July 2014
Location: IKP, TU Darmstadt
occasional visitor
From: *ikp.physik.tu-darmstadt.de
Dear Olivier,

do you have any news on the repo?


Cheers,

Christian
Re: Problem with getting agapro from the Legnaro svn repo [message #19360 is a reply to message #19348] Tue, 05 July 2016 15:20 Go to previous messageGo to next message
stezow is currently offline  stezow
Messages: 13
Registered: January 2015
occasional visitor
From: *in2p3.fr

Dear Christian,

I've asked Dino again last week and still no news. I'll do it again. Sorry for that !

Cheers
Olivier
Re: Problem with getting agapro from the Legnaro svn repo [message #19538 is a reply to message #19348] Tue, 13 September 2016 09:52 Go to previous message
stezow is currently offline  stezow
Messages: 13
Registered: January 2015
occasional visitor
From: *in2p3.fr

Dear Christian,

The svn repository is available again but at a different address.
I have modified the AgataSoftware.py script accordingly. So in principle, you can install from scratch the last version of adf/agapro/femul.

Let us know if you have any problems

Cheers
Olivier
Previous Topic: femul emulator
Goto Forum:
  


Current Time: Tue Jun 15 22:08:07 CEST 2021

Total time taken to generate the page: 0.01944 seconds