GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » [NOTSUPPORTED] Pandaroot not compiling (with fix)
[NOTSUPPORTED] Pandaroot not compiling (with fix) [message #17373] Tue, 07 October 2014 14:47 Go to next message
Marcell Steinen is currently offline  Marcell Steinen
Messages: 2
Registered: June 2012
Location: Mainz
occasional visitor
From: *kph.uni-mainz.de
Hi everybody,

I had problems installing pandaroot on my new notebook (XUbuntu 14.04 64 bit) yesterday. So it's still a pretty clean system

I installed the latest version of the external packages (jul14p3) without any problems and than tried to install pandaroot (rev: 26193) but it failed to compile. I could fix the compilation by reverting the changes done in https://subversion.gsi.de/trac/fairroot/changeset/26078. The "FairMultiLinkedData_Interface" class doesn't exist at all.

Since I got everything just from git /svn without doing any changes (only afterwards to make it compile) I think that this might have to be reverted or that it's necessary so add the "FairMultiLinkedData_Interface" classes.

greetings,

Marcell

[Updated on: Tue, 07 October 2014 15:02] by Moderator

Report message to a moderator

Re: Pandaroot not compiling (with fix) [message #17374 is a reply to message #17373] Tue, 07 October 2014 14:52 Go to previous messageGo to next message
MartinJGaluska is currently offline  MartinJGaluska
Messages: 203
Registered: March 2010
Location: Germany
first-grade participant
From: *physik.uni-giessen.de
Hi Marcell,

you need to use external packages apr13, see https://panda-wiki.gsi.de/cgi-bin/view/Computing/PandaRootFAQ.

With *buntu 14.04 there is a problem with these packages, but it was fixed in apr13p1. So I would suggest to use apr13p1.

Kind regards,
Martin
Re: Pandaroot not compiling (with fix) [message #17375 is a reply to message #17373] Tue, 07 October 2014 14:59 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *to.infn.it
Hi,
first of all, jul14p3 is not supported then you are doing a not allowed installation. As Martingis stating, apr13 is still the suggested version.
In particular, jul14p3 is comaptible with the new git base packages. if you use the old pandaroot base you have the problem with FairMultiLinkedData_Interface".

If you still want to use jul14p3, please write me a private mail and I send you the installation procedure. But you will use in thisw ay a not supported system.
Re: [NOTSUPPORTED] Pandaroot not compiling (with fix) [message #17376 is a reply to message #17373] Tue, 07 October 2014 15:08 Go to previous messageGo to next message
Marcell Steinen is currently offline  Marcell Steinen
Messages: 2
Registered: June 2012
Location: Mainz
occasional visitor
From: *kph.uni-mainz.de
ah, ok, thanks for the fast replies. I just thought that the "p" version of the external packages were just so bugfixes.

I will switch back so the "apr13" (or maybe "apr13p1" if necessary with xubuntu)

greetings,
Marcell
Re: [NOTSUPPORTED] Pandaroot not compiling (with fix) [message #17377 is a reply to message #17376] Tue, 07 October 2014 15:10 Go to previous messageGo to next message
MartinJGaluska is currently offline  MartinJGaluska
Messages: 203
Registered: March 2010
Location: Germany
first-grade participant
From: *physik.uni-giessen.de
I would suggest to use apr13p1 straight away. See here: https://forum.gsi.de/index.php?t=msg&th=4230&start=0&
Re: [NOTSUPPORTED] Pandaroot not compiling (with fix) [message #17656 is a reply to message #17373] Tue, 16 December 2014 12:20 Go to previous message
Prometeusz Jasinski is currently offline  Prometeusz Jasinski
Messages: 34
Registered: January 2012
continuous participant
From: *kph.uni-mainz.de
I ommitted this problem with dec14 external packages by changing the root version in the if statement from 5 to 6 in all cases of the 3 files (SDS and LMD).
Previous Topic: Problem on installing pandaroot
Next Topic: [FIXED] fts/FtsTracking/PndFtsHoughSpace.h::ExportTH2S() declared but not implemented
Goto Forum:
  


Current Time: Sat Jun 22 10:40:36 CEST 2024

Total time taken to generate the page: 0.00566 seconds