GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » [FIXED] error compiling pandaroot mar14
[FIXED] error compiling pandaroot mar14 [message #16200] Thu, 03 April 2014 13:54 Go to next message
SHenssler is currently offline  SHenssler
Messages: 13
Registered: March 2014
Location: FZ Jülich
occasional visitor
From: *ext.kfa-juelich.de
Hello together,

i am just trying to compile the new pandaroot version mar14, but i get the following error:

[ 24%] Built target PhotosCxxInterface
Linking Fortran shared library ../../../lib/libEvtGen.so
gfortran: error: unrecognized command line option '-stdlib=libc++'
make[2]: *** [lib/libEvtGen.0.0.0.so] Error 1
make[1]: *** [pgenerators/EvtGen/EvtGen/CMakeFiles/EvtGen.dir/all] Error 2
make: *** [all] Error 2

any suggestions?

Thanks
Simon

[Updated on: Tue, 15 April 2014 13:54] by Moderator

Report message to a moderator

Re: error compiling pandaroot mar14 [message #16201 is a reply to message #16200] Thu, 03 April 2014 14:00 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: 2.159.116*
Which Operative system and externals?
Re: error compiling pandaroot mar14 [message #16203 is a reply to message #16200] Thu, 03 April 2014 14:06 Go to previous messageGo to next message
SHenssler is currently offline  SHenssler
Messages: 13
Registered: March 2014
Location: FZ Jülich
occasional visitor
From: *ext.kfa-juelich.de
Hi,

i am using a mac with OS X mavericks and the external packages from dec13,
i had the pandaroot version from jan14 before, that worked without errors.

Cheers,
Simon
Re: error compiling pandaroot mar14 [message #16205 is a reply to message #16203] Thu, 03 April 2014 14:09 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: 2.159.116*
The release works with apr13 externals, which do not work I under maverick.
Dec13 is buggy and should be never used, my suggestion is to find another machine.
It is a problem of the fairroot external packages and not of pandaroot.
Re: error compiling pandaroot mar14 [message #16211 is a reply to message #16205] Thu, 03 April 2014 16:01 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: 93.48.231*
By the way, which compiler have you set in the installation of the externals? gcc o clang? For OS X one should use clang.
Re: error compiling pandaroot mar14 [message #16212 is a reply to message #16211] Thu, 03 April 2014 16:10 Go to previous messageGo to next message
SHenssler is currently offline  SHenssler
Messages: 13
Registered: March 2014
Location: FZ Jülich
occasional visitor
From: *unitymediagroup.de
well the externals installed just fine, at least dec13 with clang
and they also worked with the jan14 release of pandaroot

for the apr13 release there is no option for clang, i guess thats the reason it doesnt work on mavericks?
Re: error compiling pandaroot mar14 [message #16214 is a reply to message #16212] Thu, 03 April 2014 16:13 Go to previous message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: 93.48.231*
In mar14 there is a different evtgen than jan14, but in my maverick it compiles. I suppose you have a "wrong" gfortran version which sometimes give problems.
However, even it compiles, it does not mean that provides useful results.
Previous Topic: [FIXED] Compiling error trunk 24252
Next Topic: New PandaRoot release scrut14
Goto Forum:
  


Current Time: Sun Apr 21 10:33:13 CEST 2024

Total time taken to generate the page: 0.01279 seconds