GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » [FIXED] error after updating pandaroot
[FIXED] error after updating pandaroot [message #15085] Fri, 02 August 2013 09:25 Go to next message
manoj.jadhav is currently offline  manoj.jadhav
Messages: 41
Registered: February 2010
Location: Mumbai, India
continuous participant
From: 103.21.125*
Dear all,
I have updated my pandaroot trunk version and got following error while compiling,

CMake Error at CMakeLists.txt:34 (SetBasicVariables):
Unknown CMake command "SetBasicVariables".


-- Configuring incomplete, errors occurred!

Please suggest some solution.

Thank You.


Manoj Jadhav
I.I.T.Bombay
Mumbai

[Updated on: Thu, 22 August 2013 17:45] by Moderator

Report message to a moderator

Re: error after updating pandaroot [message #15086 is a reply to message #15085] Fri, 02 August 2013 12:04 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: 2.235.190*
Can you write the complete message, after you set the SIMPATH, when you type the cmake ../pandaroot command?
Re: error after updating pandaroot [message #15088 is a reply to message #15085] Fri, 02 August 2013 12:43 Go to previous messageGo to next message
manoj.jadhav is currently offline  manoj.jadhav
Messages: 41
Registered: February 2010
Location: Mumbai, India
continuous participant
From: 103.21.125*
Dear Stefano,

Thank you for reply. Here is complete massage after cmake,

CMAKE_Fortran_COMPILER full path: /usr/local/bin/gfortran
Fortran compiler: gfortran
Set BuildType DEBUG
--- Found a Mac OS X System 10.6
--- Found GNU compiler collection
--- Build Type: Debug
--- Compiler Flags: -m64
CMake Error at CMakeLists.txt:34 (SetBasicVariables):
Unknown CMake command "SetBasicVariables".


-- Configuring incomplete, errors occurred!



Manoj Jadhav
I.I.T.Bombay
Mumbai
Re: error after updating pandaroot [message #15089 is a reply to message #15088] Fri, 02 August 2013 13:43 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: 2.235.190*
Have you set properly your SIMPATH?
Can you do a

ls $SIMPATH


?
Re: error after updating pandaroot [message #15090 is a reply to message #15085] Fri, 02 August 2013 15:55 Go to previous messageGo to next message
manoj.jadhav is currently offline  manoj.jadhav
Messages: 41
Registered: February 2010
Location: Mumbai, India
continuous participant
From: 103.21.125*
This is content of my fairbuild,

ls $SIMPATH
bin doc etc include lib man share

thank you.


Manoj Jadhav
I.I.T.Bombay
Mumbai
Re: error after updating pandaroot [message #15093 is a reply to message #15085] Sat, 03 August 2013 10:29 Go to previous message
manoj.jadhav is currently offline  manoj.jadhav
Messages: 41
Registered: February 2010
Location: Mumbai, India
continuous participant
From: 103.21.124*
Dear Stefano,
Now it is compiled. Look likes problem of some conflicts.


Manoj Jadhav
I.I.T.Bombay
Mumbai
Previous Topic: [FIXED] PndAnalysis::SetVerbose()
Next Topic: [FIXED] crash in reco macro (timebased simulation)
Goto Forum:
  


Current Time: Sat Jul 13 20:42:43 CEST 2024

Total time taken to generate the page: 0.00744 seconds