GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » [FIXED] Problem in runing macro /macro/run/sim_complete.C
[FIXED] Problem in runing macro /macro/run/sim_complete.C [message #14356] Wed, 16 January 2013 14:11 Go to next message
Himani Bhatt is currently offline  Himani Bhatt
Messages: 11
Registered: October 2012
Location: Juelich
occasional visitor
From: *ikp.kfa-juelich.de
Hi,

I have successfully installed pandaroot in Suse 11.1 system.
As a beginning I start to look macros in /pandaroot/macro/run/ dir.
but while running root -l sim_complete.C, it is giving following error:
root [0]
Processing sim_complete.C...
Error: Symbol FairRunSim is not defined in current scope  sim_complete.C:33:
Error: Symbol FairRunSim is not defined in current scope  sim_complete.C:33:
Error: type FairRunSim not defined FILE:/home/bhatt/PANDA/pandaroot/macro/run/./sim_complete.C LINE:33
Warning: Automatic variable FairRunSim*fRun is allocated sim_complete.C:33:
Error: Undeclared variable FairRunSim*fRun sim_complete.C:33:
*** Interpreter error recovered ***


I tried other macro as well but getting similar error.
Is there anything else I need to do in order to run this macros.

Regards,
Himani

[Updated on: Fri, 18 January 2013 14:45] by Moderator

Report message to a moderator

Re: Problem in runing macro /macro/run/sim_complete.C [message #14357 is a reply to message #14356] Wed, 16 January 2013 14:20 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *to.infn.it
Did you run the config.sh before?
Re: Problem in runing macro /macro/run/sim_complete.C [message #14358 is a reply to message #14357] Wed, 16 January 2013 14:28 Go to previous messageGo to next message
Himani Bhatt is currently offline  Himani Bhatt
Messages: 11
Registered: October 2012
Location: Juelich
occasional visitor
From: *ikp.kfa-juelich.de
Yes I did this in buildpanda dir itself.
Re: Problem in runing macro /macro/run/sim_complete.C [message #14359 is a reply to message #14356] Wed, 16 January 2013 14:47 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *to.infn.it
Which version of the code you are using?
And can you put here your config.sh? It seems you are not properly loading the environment variables.
Re: Problem in runing macro /macro/run/sim_complete.C [message #14360 is a reply to message #14356] Wed, 16 January 2013 15:21 Go to previous messageGo to next message
Himani Bhatt is currently offline  Himani Bhatt
Messages: 11
Registered: October 2012
Location: Juelich
occasional visitor
From: *ikp.kfa-juelich.de
the svn info is following:

bhatt@ikp398:~/PANDA/pandaroot/macro/run> svn info
Path: .
URL: https://subversion.gsi.de/fairroot/pandaroot/trunk/macro/run
Repository Root: https://subversion.gsi.de/fairroot
Repository UUID: 0381ead4-6506-0410-b988-94b70fbc4730
Revision: 18287
Node Kind: directory
Schedule: normal
Last Changed Author: spataro
Last Changed Rev: 18235
Last Changed Date: 2013-01-03 17:44:01 +0100 (Thu, 03 Jan 2013)


and config.sh file is attached here.
  • Attachment: config.sh
    (Size: 3.15KB, Downloaded 230 times)
Re: Problem in runing macro /macro/run/sim_complete.C [message #14361 is a reply to message #14360] Wed, 16 January 2013 16:17 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *to.infn.it
Ok,
can you copy here what is printing after you execute the config.sh, and what is appearing after you run the macro? it seems that you cut some part of the log message.
Re: Problem in runing macro /macro/run/sim_complete.C [message #14362 is a reply to message #14361] Thu, 17 January 2013 09:54 Go to previous messageGo to next message
Himani Bhatt is currently offline  Himani Bhatt
Messages: 11
Registered: October 2012
Location: Juelich
occasional visitor
From: *ikp.kfa-juelich.de
While giving ./config.sh command it shows:

System during compilation: Welcome to openSUSE 11.1 - Kernel  r ( l).
                           x86_64
System now               : Welcome to openSUSE 11.1 - Kernel  r ( l).
                           x86_64


and when I run the code it gives:


bhatt@ikp398:~/PANDA/pandaroot/macro/run> root -l sim_complete.C
root [0]
Processing sim_complete.C...
Error: Symbol FairRunSim is not defined in current scope  sim_complete.C:33:
Error: Symbol FairRunSim is not defined in current scope  sim_complete.C:33:
Error: type FairRunSim not defined FILE:/home/bhatt/PANDA/pandaroot/macro/run/./sim_complete.C LINE:33
Warning: Automatic variable FairRunSim*fRun is allocated sim_complete.C:33:
Error: Undeclared variable FairRunSim*fRun sim_complete.C:33:
*** Interpreter error recovered ***
root [1]        


One thing I found when I give source check_system.sh in buildpanda dir myself, it is giving such statement:

bhatt@ikp398:~/PANDA/pandaroot/buildpanda> source check_system.sh
System during compilation:

System now               : Welcome to openSUSE 11.1 - Kernel  r ( l).
                           x86_64
You try to run the software on a different
linux flavour than it was compuiled on.
This is normaly a serious error, so we stop
the execution at this point.
If you know what you do you can change the
config.sh script to bypass this security issue.
You try to run the software on a different
linux flavour than it was compuiled on.
This is normaly a serious error, so we stop
the execution at this point.
If you know what you do you can change the
config.sh script to bypass this security issue.
bhatt@ikp398:~/PANDA/pandaroot/buildpanda>        




Re: Problem in runing macro /macro/run/sim_complete.C [message #14363 is a reply to message #14362] Thu, 17 January 2013 10:25 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *to.infn.it
It seems that the following lines are not executed:

  gROOT->LoadMacro("$VMCWORKDIR/gconfig/rootlogon.C");
  rootlogon();


Have you modified your sim_complete.C?
Re: Problem in runing macro /macro/run/sim_complete.C [message #14364 is a reply to message #14363] Thu, 17 January 2013 11:45 Go to previous messageGo to next message
Himani Bhatt is currently offline  Himani Bhatt
Messages: 11
Registered: October 2012
Location: Juelich
occasional visitor
From: *ikp.kfa-juelich.de
No, I didn't modified that file.
Re: Problem in runing macro /macro/run/sim_complete.C [message #14365 is a reply to message #14364] Thu, 17 January 2013 11:47 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *to.infn.it
Can you execute these lines from your root shell?

gROOT->LoadMacro("$VMCWORKDIR/gconfig/rootlogon.C");
rootlogon();
Re: Problem in runing macro /macro/run/sim_complete.C [message #14366 is a reply to message #14365] Thu, 17 January 2013 12:24 Go to previous messageGo to next message
Himani Bhatt is currently offline  Himani Bhatt
Messages: 11
Registered: October 2012
Location: Juelich
occasional visitor
From: *ikp.kfa-juelich.de
Yes I tried it. I don't know whether it should show some additional messages but in my case when I execute this command it is like this:
bhatt@ikp398:~/PANDA/pandaroot/macro/run> root -l
root [0] gROOT->LoadMacro("$VMCWORKDIR/gconfig/rootlogon.C");
root [1] rootlogon();
root [2] 
Re: Problem in runing macro /macro/run/sim_complete.C [message #14367 is a reply to message #14366] Thu, 17 January 2013 12:25 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *to.infn.it
It is not working. Can you check if $VMCWORKDIR is set?
Re: Problem in runing macro /macro/run/sim_complete.C [message #14368 is a reply to message #14367] Thu, 17 January 2013 12:54 Go to previous messageGo to next message
Himani Bhatt is currently offline  Himani Bhatt
Messages: 11
Registered: October 2012
Location: Juelich
occasional visitor
From: *ikp.kfa-juelich.de
My bashrc looks like:

export ROOTSYS="$HOME/PANDA/sep12/tools/root/"
export SIMPATH=$HOME/PANDA/INSTALL/
export VMCWORKDIR=$HOME/PANDA/pandaroot
export PATH=$PATH:$SIMPATH/bin
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$SIMPATH/lib:$SIMPATH/lib/root


Re: Problem in runing macro /macro/run/sim_complete.C [message #14369 is a reply to message #14368] Thu, 17 January 2013 14:57 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *to.infn.it
You don't have to set such variables in the .bashrc, they could conflict.
The environment is set after you launch the:

. ./config.sh


Can you remove such voices in your bash rc, open a new terminal, launch the config, do:

echo $VMCWORKDIR
ls $VMCWORKDIR/gconfig/rootlogon.C


and put here the output? Probably you screwed such variables.
Re: Problem in runing macro /macro/run/sim_complete.C [message #14373 is a reply to message #14369] Fri, 18 January 2013 13:15 Go to previous message
Himani Bhatt is currently offline  Himani Bhatt
Messages: 11
Registered: October 2012
Location: Juelich
occasional visitor
From: *ikp.kfa-juelich.de
Now its working. I removed the stuffs from the bashrc and execute: . ./config.sh. Before I was executing with wrong command: ./config.sh

Thanks a lot.
Previous Topic: make for PndTools/MVA
Next Topic: [FIXED] Tracking + Truth Match Problem
Goto Forum:
  


Current Time: Sat Apr 13 14:39:16 CEST 2024

Total time taken to generate the page: 0.01142 seconds