GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » Fairroot » General Discussion » fairbase does not compiile properly as is (10-5-12) [SOLVED]
fairbase does not compiile properly as is (10-5-12) [SOLVED] [message #14060] Fri, 05 October 2012 16:53 Go to next message
Raphael Cervantes is currently offline  Raphael Cervantes
Messages: 34
Registered: September 2012
Location: Stony Brook University
continuous participant
From: *physics.sunysb.edu
Hey,
I tried a fresh new install of fairbase on my Ubuntu 12.04 64 bit. My external packages sep12 compiled without a hitch. I then tried to compile

svn co https://subversion.gsi.de/fairroot/fairbase/release fairroot
mkdir build
cd build
export SIMPATH=path to/sep12-build
cmake ..
make

The errors that I get are contained in the file makeAsIs.txt.

To have the command make work, I had to comment out add_subdirectory(datamatch) and add_subdirectory(test).

Did anyone else using Ubuntu 12.04 get fairbase to compile without having to modify it? I'm wondering whether the package is buggy or if I'm doing something wrong. I'm also wondering if all my troubles right now are caused by me not compiling these two directories.
  • Attachment: makeAsIs.txt
    (Size: 40.55KB, Downloaded 371 times)

[Updated on: Fri, 12 October 2012 11:16] by Moderator

Report message to a moderator

Re: fairbase does not compile properly as is (10-5-12) [message #14061 is a reply to message #14060] Fri, 05 October 2012 17:02 Go to previous messageGo to next message
Raphael Cervantes is currently offline  Raphael Cervantes
Messages: 34
Registered: September 2012
Location: Stony Brook University
continuous participant
From: *physics.sunysb.edu
Also, has anyone had any luck using geant4 with the current fairbase?

I tried running the rutherford example,
cd fairbase/examples/rutherford/macros
root run_rutherford.C
And it seemed to run without a hitch.

However, run_rutherford as it is in the repository uses Geant3. I want to use Geant4, so I replace run->SetName("TGeant3"); with run->SetName("TGeant4");
After I try to run_rutherford.C again, I get a segmentation fault. The error is described in geant4SeFault.txt. I naively copied g4libs.C from sep12/transport/geant4_vmc into my sep12-build/share/root/macros and into my gconfig folder in my fairbase. Note: the g4libs.C was not found at all in my sep12 build folder, which might suggest that sep12 is faulty in this aspect. After copying g4libs.C into said folders, I ran rutherford again and obtained the error described in geant4now.txt. I don't know what else to try, so any help is greatly appreciated.

Thank you in advance
Re: fairbase does not compile properly as is (10-5-12) [message #14062 is a reply to message #14061] Fri, 05 October 2012 17:28 Go to previous messageGo to next message
Raghav Kunnawalkam is currently offline  Raghav Kunnawalkam
Messages: 63
Registered: February 2012
Location: Stony Brook, New York
continuous participant
From: *physics.sunysb.edu
Hi Guys

I am also having the same problem regarding Geant4 and the fairdatamatch libraries.

Since i was using the Jan10 release for a while i though that geant4 needed CLHEP to work, but you guys say in your current release it is integrated with Geant4.

As always any help is much appreciated.

Cheers
Raghav
Re: fairbase does not compiile properly as is (10-5-12) [message #14065 is a reply to message #14060] Mon, 08 October 2012 17:27 Go to previous messageGo to next message
Florian Uhlig is currently offline  Florian Uhlig
Messages: 424
Registered: May 2007
first-grade participant
From: *pools.arcor-ip.net
Hi Raphael,

sorry for the late response. Both issues are fixed in the latest version of fairbase. So please update your local working copy and try again.

Ciao

Florian
Re: fairbase does not compiile properly as is (10-5-12) [message #14066 is a reply to message #14065] Mon, 08 October 2012 17:52 Go to previous messageGo to next message
Raghav Kunnawalkam is currently offline  Raghav Kunnawalkam
Messages: 63
Registered: February 2012
Location: Stony Brook, New York
continuous participant
From: *bnl.gov
Hi Florian

Thanks for your reply. I did the update and it looks like there are no problems regarding FairDataMatch.

But the geant4 is still not working.

There are different errors regarding where i place the g4libs.C file (do we need it actually here?). I remember that there was this same problem before and I solved it by pasting that file in some place where fairroot was looking for it. ( https://forum.gsi.de/index.php?t=tree&th=3614&start=0&rid=17 88&S=2ec8d4daab8502a0c37cbf69f69a6a02#page_top)

So it still gives me the following error regarding Geant4
-I- FairGeoMedia Read media
[INFO ] [08.10.2012 11:50:50] [FairRunSim.cxx::Init:165] Create visualisation manager
[INFO ] [08.10.2012 11:50:50] [FairRunSim.cxx::SetMCConfig:262] ---User path for Configuration (g4libs.C) is used : /Users/raghav/EICROOT/fairroot/example/gconfig/
[INFO ] [08.10.2012 11:50:50] [FairRunSim.cxx::SetMCConfig:269] ---User path for Configuration (g4Config.C) is used : /Users/raghav/EICROOT/fairroot/example/gconfig/
[INFO ] [08.10.2012 11:50:50] [FairRunSim.cxx::SetMCConfig:331] ---User path for Cuts and Processes (SetCuts.C) is used : /Users/raghav/EICROOT/fairroot/example/gconfig/
Loading Geant4 global libraries ...Our Macro
Loading Library libG4Tree
Loading Library libG4FR
Loading Library libG4GMocren
Loading Library libG4visHepRep
Loading Library libG4RayTracer
Loading Library libG4VRML
Loading Library libG4vis_management
Loading Library libG4modeling
Loading Library libG4interfaces
Loading Library libG4persistency
Loading Library libG4analysis
Loading Library libG4error_propagation
Loading Library libG4readout
Loading Library libG4physicslists
Loading Library libG4run
Loading Library libG4event
Loading Library libG4tracking
Loading Library libG4parmodels
Loading Library libG4processes
Loading Library libG4digits_hits
Loading Library libG4track
Loading Library libG4particles
Loading Library libG4geometry
Loading Library libG4materials
Loading Library libG4graphics_reps
Loading Library libG4intercoms
Loading Library libG4global
Loading Library libG4clhep
Loading g4root library ...
Loading libraries ... finished
dyld: lazy symbol binding failed: Symbol not found: __ZN6RootGM7FactoryC1Ev
Referenced from: /Users/raghav/EICROOT/sep12-build/lib/libgeant4vmc.so
Expected in: flat namespace

dyld: Symbol not found: __ZN6RootGM7FactoryC1Ev
Referenced from: /Users/raghav/EICROOT/sep12-build/lib/libgeant4vmc.so
Expected in: flat namespace


As always many thanks for your help
Cheers
Raghav
Re: fairbase does not compiile properly as is (10-5-12) [message #14067 is a reply to message #14066] Mon, 08 October 2012 18:28 Go to previous messageGo to next message
Raphael Cervantes is currently offline  Raphael Cervantes
Messages: 34
Registered: September 2012
Location: Stony Brook University
continuous participant
From: *bnl.gov
Hi Florian,
Thank you for fixing issues regarding cmake. However, like Raghav, I am still having problems running Geant4 with the rutherford example. I get the exact same errors that I described in my second post. Has anyone else besides Raghav and myself ran into any issues running geant4? Has anyone come up with a solution?

Again, thank you Florian for your response.

-Raphael
Re: fairbase does not compiile properly as is (10-5-12) [message #14092 is a reply to message #14067] Thu, 11 October 2012 12:44 Go to previous messageGo to next message
Florian Uhlig is currently offline  Florian Uhlig
Messages: 424
Registered: May 2007
first-grade participant
From: *gsi.de
Hi Raphael,

the problem with Geant4 is fixed now, so please update your local working copy and try again.

If the problem is solved for you please add the string [SOLVED] to the topics of the two threads.

Ciao

Florian
Re: fairbase does not compiile properly as is (10-5-12) [message #14106 is a reply to message #14092] Fri, 12 October 2012 01:03 Go to previous messageGo to next message
Raphael Cervantes is currently offline  Raphael Cervantes
Messages: 34
Registered: September 2012
Location: Stony Brook University
continuous participant
From: *dyn.optonline.net
[SOLVED]
Re: fairbase does not compiile properly as is (10-5-12) [SOLVED] [message #14107 is a reply to message #14060] Fri, 12 October 2012 11:19 Go to previous message
Florian Uhlig is currently offline  Florian Uhlig
Messages: 424
Registered: May 2007
first-grade participant
From: *gsi.de
Hi Raphael,

I meant changing the title of the first message of this thread, which I did now. This is the topic which is shown in the list of all topics. Changing this after the topic is solved helps keeping track of problems.

Ciao

Florian
Previous Topic: New update (9/18/2012) not working
Next Topic: Geant4 not working with current fairbase (10/10/12) [SOLVED]
Goto Forum:
  


Current Time: Mon Apr 22 14:16:33 CEST 2024

Total time taken to generate the page: 0.00846 seconds