GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » Fairroot » External Packages » Problem in installing fairsoft jan12
Problem in installing fairsoft jan12 [message #13897] Tue, 28 August 2012 14:02 Go to next message
Ajay Kumar is currently offline  Ajay Kumar
Messages: 102
Registered: December 2011
Location: indore
continuous participant

From: *iitidr.ac.in
Hi,

I have downloaded the fairsoft (jan12 version )through svn command.
Since Geant4 is downloaded while we are configuring using the command ./Configure.sh. Somehow it is not downloading GEANT4 and giving error (see attached file).

After that I downloaded all those files directly from the
http://geant4.cern.ch/support/source and kept it in "transport" directory.
But I was not able to install either way.

What is the solution?

Ajay





  • Attachment: error
    (Size: 0.13KB, Downloaded 218 times)


AJAY KUMAR
Research scholar
Indian Institute of Technology Indore,Indore
Madhya Pradesh
India
Re: Problem in installing fairsoft jan12 [message #13898 is a reply to message #13897] Tue, 28 August 2012 14:19 Go to previous messageGo to next message
Florian Uhlig is currently offline  Florian Uhlig
Messages: 424
Registered: May 2007
first-grade participant
From: *gsi.de
Hi Ajay,

this is not a error message where you have to choose the compiler you want to use. After this menu there are more questions to be answered. Only after this step the compilation of the external packages will start.

Ciao

Florian
Re: Problem in installing fairsoft jan12 [message #13899 is a reply to message #13898] Tue, 28 August 2012 15:25 Go to previous messageGo to next message
Ajay Kumar is currently offline  Ajay Kumar
Messages: 102
Registered: December 2011
Location: indore
continuous participant

From: *iitidr.ac.in
Hi..Florian

Sorry. I forgot to attach whole file. I have attached complete error file now so you can see.


Regards
Ajay
  • Attachment: error
    (Size: 9.06KB, Downloaded 192 times)


AJAY KUMAR
Research scholar
Indian Institute of Technology Indore,Indore
Madhya Pradesh
India
Re: Problem in installing fairsoft jan12 [message #13900 is a reply to message #13898] Tue, 28 August 2012 16:05 Go to previous messageGo to next message
Ajay Kumar is currently offline  Ajay Kumar
Messages: 102
Registered: December 2011
Location: indore
continuous participant

From: *iitidr.ac.in
Hi..Florian

Sorry. I forgot to attach whole file. I have attached complete error file now so you can see.


Regards
Ajay
  • Attachment: error
    (Size: 9.06KB, Downloaded 153 times)


AJAY KUMAR
Research scholar
Indian Institute of Technology Indore,Indore
Madhya Pradesh
India
Re: Problem in installing fairsoft jan12 [message #13901 is a reply to message #13899] Tue, 28 August 2012 16:09 Go to previous messageGo to next message
Florian Uhlig is currently offline  Florian Uhlig
Messages: 424
Registered: May 2007
first-grade participant
From: *gsi.de
Hi Ajay,

unfortunately with the new version of Geant4 it isn't possible to simply copy the files to geant4 source directory. The geant4 installation process always tries to download the files from the web server.

The solution for you is to switch of the automatic installation of the geant4 data files and download them as you already did. After this step you have to copy them to the right position and unpack them.

Since you don't install the external packages into an installation directory you have to create the following directory in the geant4 directory

mkdir share/Geant4/data

Move the downloaded data files into this directory and unpack them. This should do the job.

Ciao

Florian

[Updated on: Tue, 28 August 2012 16:25]

Report message to a moderator

Re: Problem in installing fairsoft jan12 [message #13919 is a reply to message #13901] Sat, 01 September 2012 17:47 Go to previous messageGo to next message
Ajay Kumar is currently offline  Ajay Kumar
Messages: 102
Registered: December 2011
Location: indore
continuous participant

From: *iitidr.ac.in
Hi Florian
Thank you very much for your quick reply.

But still Something is not clear to me from your last reply.

Q. how to switch of the automatic installation of the geant4 data files ?
I have tried to do that after switch off the geant4 file inside the ./configure.sh but again same error is coming.

Again I have done as you told me and tried with both the options with internet & Directory but same error is appearing.
I am attaching here error file which are coming from both the way.Plz see them & kindly tell me what I have to do.



Thanks & Regards
Ajay
  • Attachment: errorGeant4
    (Size: 18.28KB, Downloaded 172 times)


AJAY KUMAR
Research scholar
Indian Institute of Technology Indore,Indore
Madhya Pradesh
India
Re: Problem in installing fairsoft jan12 [message #13925 is a reply to message #13919] Tue, 04 September 2012 13:08 Go to previous messageGo to next message
Ajay Kumar is currently offline  Ajay Kumar
Messages: 102
Registered: December 2011
Location: indore
continuous participant

From: *iitidr.ac.in
Hi,
I was trying to geant4 in both ways.

I have seen that in configure.sh following two scripts
for installation geant4 ( one is commented).

if [ "$check" = "1" ];
then
source scripts/install_geant4.sh
# source scripts/install_geant4_includes.sh
fi

##################### GEANT 4 Data #############################################

#if [ "$check" = "1" -a "$geant4_data_files" = "yes" ];
#then
# source scripts/install_geant4_data.sh
#fi


If I uncomment the later one, then it is downloading through wget.
Can I use the then " install_geant4_data.sh"?

or If someone tell me how the downloading is done in install_geant4.sh? I could not understand from the code.

Help is needed.

ajay


AJAY KUMAR
Research scholar
Indian Institute of Technology Indore,Indore
Madhya Pradesh
India
Re: Problem in installing fairsoft jan12 [message #13926 is a reply to message #13919] Tue, 04 September 2012 13:27 Go to previous messageGo to next message
Florian Uhlig is currently offline  Florian Uhlig
Messages: 424
Registered: May 2007
first-grade participant
From: *gsi.de
Hi Ajay,

how fast you need the solution? If you have some more days you can use the new version of the external packages where the problem is fixed.

I expect that the old solution with wget will not work in your case. If it works you can try to use this version.

The Geant4 installation process is since version 9.4.0 downloading the data files automatically so our old installation scheme of the data files is not needed any longer and thus commented.

Ciao

Florian

Re: Problem in installing fairsoft jan12 [message #13927 is a reply to message #13926] Tue, 04 September 2012 14:17 Go to previous messageGo to next message
Ajay Kumar is currently offline  Ajay Kumar
Messages: 102
Registered: December 2011
Location: indore
continuous participant

From: *iitidr.ac.in
Hi,
Sorry to disturb you again and again.
I have following doubts.

Automatic downloading through internet -

I have problem in automatic downloading. Like earlier I was trying through wget, it was not working. Then I had given path to .wgetrc file and now wget working in my pc.

Similarly now for automatic downloading - what do I have to do in my pc that it works?

That is not clear to me.





Using Directory -

I have downloaded the following files -
G4ABLA.3.0.tar.gz
G4EMLOW.6.23.tar.gz
G4NDL.4.0.tar.gz
G4NEUTRONXS.1.1.tar.gz

going to the CERN website. Then I have kept above files in ~/fairsoft/transport/geant4/share/Geant4/data

Then I did untar.

Next I have used option 3 ( directory) while configuring. Still I could not do it.

I cant wait because I have deleted my older version also from my pc.

Please give some solution or some alternative.







AJAY KUMAR
Research scholar
Indian Institute of Technology Indore,Indore
Madhya Pradesh
India
Re: Problem in installing fairsoft jan12 [message #13928 is a reply to message #13927] Tue, 04 September 2012 14:53 Go to previous messageGo to next message
Florian Uhlig is currently offline  Florian Uhlig
Messages: 424
Registered: May 2007
first-grade participant
From: *gsi.de
Hi Ajay,

can you please try to set the following environment variable before you run the configure script where host and port has to be set according to your proxy.

export http_proxy="http://host:port"

The problem with geant4 is that the first configuration which was created by cmake is
not overridden when you run a second time. To force geant4 to run cmake again you have to remove the CMakeCache.txt in directory transport/geant4/build. If yon now run configure.sh again with different settings they should be accepted by geant4.

Before you do that please try setting the environment variable first.

Ciao

Florian
Re: Problem in installing fairsoft jan12 [message #13942 is a reply to message #13928] Thu, 06 September 2012 17:29 Go to previous messageGo to next message
Ajay Kumar is currently offline  Ajay Kumar
Messages: 102
Registered: December 2011
Location: indore
continuous participant

From: *iitidr.ac.in
Hello Florian,

I have done proxy setting inside the configure script and removed the CMakeCache.txt in directory transport/geant4/build.then I run configure.sh again but still am getting the same error.

Now I have tried with new release (sep12),again my system could not download the geant4 data files through Internet option.same error (vgm could not be created) was coming.
Then I went through directory option,I have download all the geant4 files from the given link in the INSTALL file and put & unpack them inside the transport directory.also create the separate directory for installation named as fairroot.
Then I run configure.sh again and finaly I was able to install external packages without errors.

But When I checked for root than somehow it is giving following error:-

Couldn't find font "-adobe-helvetica-medium-r-*-*-10-*-*-*-*-*-iso8859-1",
trying "fixed". Please fix your system so helvetica can be found,
this font typically is in the rpm (or pkg equivalent) package
XFree86-[75,100]dpi-fonts or fonts-xorg-[75,100]dpi.
/home/ajay/fairroot/bin/root.exe: error while loading shared libraries: libCore.so.5.34: cannot open shared object file: No such file or directory

Then I started script again but still same error is there.
but if I will configure root separately inside the ~/fairsoft/tools/root/ then root works fine.

Again needed your help Sad


Thanks in advance


AJAY KUMAR
Research scholar
Indian Institute of Technology Indore,Indore
Madhya Pradesh
India
Re: Problem in installing fairsoft jan12 [message #13944 is a reply to message #13942] Fri, 07 September 2012 07:48 Go to previous messageGo to next message
Ajay Kumar is currently offline  Ajay Kumar
Messages: 102
Registered: December 2011
Location: indore
continuous participant

From: *iitidr.ac.in
Hi Florian,

Sorry,Now It is solved. I did not set environment variable properly.I was setting host & port without username & password inside the configure.sh. after making following setting in my .bashrc I am able to install without any errors.

export http_proxy="http://username:password@host:port"


Thank you very much



AJAY KUMAR
Research scholar
Indian Institute of Technology Indore,Indore
Madhya Pradesh
India
Re: Problem in installing fairsoft jan12 [message #13945 is a reply to message #13944] Fri, 07 September 2012 09:29 Go to previous messageGo to next message
Florian Uhlig is currently offline  Florian Uhlig
Messages: 424
Registered: May 2007
first-grade participant
From: *gsi.de
Hi Ajay,

Good to know that one can define the proxy as you did. I think you have been the first one with this problem.

Is now everything working or do you have still problems with Root?

Ciao

Florian
Problem in the installation of fairsoft sep12 [message #13952 is a reply to message #13945] Sun, 09 September 2012 22:10 Go to previous message
Ajay Kumar is currently offline  Ajay Kumar
Messages: 102
Registered: December 2011
Location: indore
continuous participant

From: *iitidr.ac.in
Hi Florian,

Everything is working fine with fairsoft jan12 on my ubentu 12.04 desktop now.but I was trying to install side by side fairroot sep12 version on my machine by creating another user,I saw everything goes fine without any error but as earlier I reported problem with root. it is still there.

Is it problem in my system or with this new version sep12?

Plz have a look.

Installation Directory: /home/ajay2/buildsep12
Found cmake version 2.8.9 which is newer than the
required version 2.8.6 in PATH
This version is okay. Don't install cmake as external package.
-- Found Subversion: /usr/bin/svn (found version "1.6.17")
-- FairSoft Revision - 17025 Branch - https://subversion.gsi.de/fairroot/fairsoft/release/sep12
-- Configuring done
-- Generating done
-- Build files have been written to: /home/ajay2/sep12/build
*** Package gtest is OK ***
*** Package glpk is OK ***
*** Package gsl is OK ***
*** Package Boost is OK ***
*** Package ApMon is OK ***
*** Package ml-gsoapclient is OK ***
*** Package Pythia6 is OK ***
*** Package pythia8 is OK ***
*** Package Geant4-Source is OK ***
*** Package Geant4-lib is OK ***
*** Package root is OK ***
*** Package pluto is OK ***
*** Package Geant3 is OK ***
*** Package VGM is OK ***
*** Package Geant4_VMC is OK ***
*** End installation of external packages without Errors***

Error is this :-
ajay2@panda:~$ root
Couldn't find font "-adobe-helvetica-medium-r-*-*-10-*-*-*-*-*-iso8859-1",
trying "fixed". Please fix your system so helvetica can be found,
this font typically is in the rpm (or pkg equivalent) package
XFree86-[75,100]dpi-fonts or fonts-xorg-[75,100]dpi.
/home/ajay2/buildsep12/bin/root.exe: error while loading shared libraries: libCore.so.5.34: cannot open shared object file: No such file or directory


Thankyou


AJAY KUMAR
Research scholar
Indian Institute of Technology Indore,Indore
Madhya Pradesh
India
Previous Topic: compiling jan12 on OSX Mountain Lion
Next Topic: New external packages release sep12
Goto Forum:
  


Current Time: Thu Oct 21 06:14:13 CEST 2021

Total time taken to generate the page: 0.01904 seconds