GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » Hades » Pluto » Error in Installing on MAC OSX
Error in Installing on MAC OSX [message #13818] Thu, 26 July 2012 01:52 Go to next message
Michael Kunkel is currently offline  Michael Kunkel
Messages: 53
Registered: June 2011
continuous participant
From: *hr.hr.cox.net
Hello,

I am attempting to install pluto++ on a Mac OSX Lion.

For the plug PSaidLowEnergy, I get the following error.


plugins/scatter_mod/PSaidLowEnergy.cc:201: error: call of overloaded 'pow(long double, double&)' is ambiguous
/Users/Mike/root/include/TMath.h:390: note: candidates are: double pow(double, double)
Re: Error in Installing on MAC OSX [message #13834 is a reply to message #13818] Wed, 01 August 2012 13:45 Go to previous messageGo to next message
Ingo Froehlich is currently offline  Ingo Froehlich
Messages: 167
Registered: March 2004
Location: IKF - Frankfurt
first-grade participant
From: *x-matter.uni-frankfurt.de
I have no MAC to test this error, but maybe you could try to change all "pow" functions where the cast to "long double" is used to "powl"

--
Ingo Froehlich
IKF - University of Frankfurt
069-798-47027, FAX: -47024
Re: Error in Installing on MAC OSX [message #13845 is a reply to message #13834] Mon, 06 August 2012 18:30 Go to previous messageGo to next message
Michael Kunkel is currently offline  Michael Kunkel
Messages: 53
Registered: June 2011
continuous participant
From: 129.57.112*
I had tried that, and it worked.
PLUTO built without error codes, but will not run.
Whenever I attempt to execute a macro I get errors.

I know you have no Mac to test on. But here is a simple macro that gets denied.

#include "TH1.h"
#include "TH2.h"
#include "TH3.h"
#include "TChain.h"
#include "TCanvas.h"
#include "TF1.h"
#include "/Users/Mike/Pluto/INSTALL_DIR/loadPluto.h"
#include "/Users/Mike/Pluto/INSTALL_DIR/include/pluto/PParticle.h"
#include "/Users/Mike/Pluto/INSTALL_DIR/include/pluto/PReaction.h"
#include "/Users/Mike/Pluto/INSTALL_DIR/include/pluto/PBeamSmearing.h"

void SIMULATE_Eta_Dalitz(){

    gROOT->Reset();

    PReaction my_reaction("_P1 = 2.2","g","p","p eta [dilepton [e+ e-] g]","eta_",1,0,0,0);
    my_reaction.Loop(25000);

}




Error: PReaction() declared but not defined SIMULATE_Eta_Dalitz.C:16:
Error: ~PReaction() declared but not defined SIMULATE_Eta_Dalitz.C:16:
*** Interpreter error recovered ***
Re: Error in Installing on MAC OSX [message #13846 is a reply to message #13845] Mon, 06 August 2012 18:38 Go to previous messageGo to next message
Ingo Froehlich is currently offline  Ingo Froehlich
Messages: 167
Registered: March 2004
Location: IKF - Frankfurt
first-grade participant
From: *x-matter.uni-frankfurt.de
I think its a linking problem

Could you try to do "make Pluto"? It should do a dummy linking to an executable


--
Ingo Froehlich
IKF - University of Frankfurt
069-798-47027, FAX: -47024
Re: Error in Installing on MAC OSX [message #13847 is a reply to message #13846] Mon, 06 August 2012 20:01 Go to previous messageGo to next message
Michael Kunkel is currently offline  Michael Kunkel
Messages: 53
Registered: June 2011
continuous participant
From: 129.57.112*
When I "make Pluto"
I get message that libraries are done
ie:
Mike-Kunkels-MacBook:pluto_v5.40 Mike$ make
Libraries done.

I have an libPluto.a libPluto.dylib libPluto.so
In my rootlogon.C I link to the libPluto.so

Is there something else I am missing?
Re: Error in Installing on MAC OSX [message #13849 is a reply to message #13847] Mon, 06 August 2012 23:40 Go to previous messageGo to next message
Ingo Froehlich is currently offline  Ingo Froehlich
Messages: 167
Registered: March 2004
Location: IKF - Frankfurt
first-grade participant
From: *dip.t-dialin.net
So not a linking error...

Does this error happen with all macros?

BTW what is libPluto.dylib?


--
Ingo Froehlich
IKF - University of Frankfurt
069-798-47027, FAX: -47024
Re: Error in Installing on MAC OSX [message #13851 is a reply to message #13849] Tue, 07 August 2012 00:31 Go to previous messageGo to next message
Michael Kunkel is currently offline  Michael Kunkel
Messages: 53
Registered: June 2011
continuous participant
From: *hr.hr.cox.net
Yes this error occurs with all macros that I use for PLUTO.

libPluto.dylib was a dynamic link created by the .sh script used to build PLUTO.

The makefile that comes with PLUTO does not work for Mac OS X.
So what I noticed was that there was a path for a PLUTO installation in the HADES simulation installation package. I modified that script to install PLUTO on Mac OS X.
PLUTO installed correctly without errors, so I am assuming the script worked.

I am attaching the scripts. All that needs to be run is configure.sh

Re: Error in Installing on MAC OSX [message #13874 is a reply to message #13818] Tue, 21 August 2012 08:37 Go to previous message
Michael Kunkel is currently offline  Michael Kunkel
Messages: 53
Registered: June 2011
continuous participant
From: *hr.hr.cox.net
Greetings

I have solved this small hiccup.
I am attaching a .tar file which will install PLUTO++ >= 5.4 on any UNIX machine.
Was tested on Ubuntu, and Mac 10.7.4 Lion

Instructions:
Untar PLUTO_UNIX_Install.tar in the directory where pluto_v5.40.x
is located. Change directory to PLUTO_INSTALL_scripts
cd PLUTO_INSTALL_scripts
source configure.sh

By default PLUTO will be installed in the pluto_v5.40.x directory,
however there is an option to install in in any directory.

I hope this helps anyone trying to use PLUTO on a Mac.

Michael
Previous Topic: Multiple branches in the Pluto-file
Next Topic: New Pluto web page
Goto Forum:
  


Current Time: Sat Nov 27 18:39:48 CET 2021

Total time taken to generate the page: 0.02299 seconds