GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » Hades » Pluto » [SOLVED] Beam Smearing
[SOLVED] Beam Smearing [message #13314] Thu, 12 April 2012 19:43 Go to next message
Michael Kunkel is currently offline  Michael Kunkel
Messages: 53
Registered: June 2011
continuous participant
From: *hr.hr.cox.net
I simulated 1 giga eta dalitz events using a smeared photon beam.
The smearing was a brem 1/E function.
The commands look as
    double ebeam_min = 1.1725;
    double ebeam_max = 5.44575;
    PBeamSmearing *beam_smear = new PBeamSmearing("beam_smear", "Beam smearing");

    TF1* beam_smear_fn = new TF1("beam_smear_fn", "-3.82136e-03 + 7.24636e-02/x", ebeam_min, ebeam_max);    

    beam_smear->SetReaction("g + p");
    beam_smear->SetMomentumFunction(beam_smear_fn);
    makeDistributionManager()->Add(beam_smear);

    PReaction my_reaction("_P1 = 2.2","g","p","p eta [dilepton [e+ e-] g]","eta_dalitz",1,0,0,0);

The code compiles and runs correctly, however I see the following message "Warning in <PBeamSmearing::Init>: No smearing model found". Is this normal?

The reason I inquire about this is that after I create the PLUTO generated events, I run them through the JLab Monte-Carlo package, which is a GEANT based physics package. Afterward The reconstructed beam profile appears nothing like the actual data, nor does the leptons momenta spectrum. This is my first step in solving this.

[Updated on: Wed, 22 May 2013 12:39] by Moderator

Report message to a moderator

Re: Beam Smearing [message #13315 is a reply to message #13314] Thu, 12 April 2012 21:14 Go to previous messageGo to next message
Ingo Froehlich is currently offline  Ingo Froehlich
Messages: 167
Registered: March 2004
Location: IKF - Frankfurt
first-grade participant
From: *dip.t-dialin.net
Hmm, I did a quick test with the recent version (v5.40.1) using the following macro:

{

    double ebeam_min = 1.1725;
    double ebeam_max = 5.44575;
    PBeamSmearing *beam_smear = new PBeamSmearing("beam_smear", "Beam smearing");
    
    TF1* beam_smear_fn = new TF1("beam_smear_fn", "-3.82136e-03 + 7.24636e-02/x", ebeam_min, ebeam_max);    
    
    beam_smear->SetReaction("g + p");
    beam_smear->SetMomentumFunction(beam_smear_fn);
    makeDistributionManager()->Add(beam_smear);

    TH1F * histo1 = new TH1F ("histo1","c.m.",100,1.,4.);

    PReaction my_reaction("_P1 = 2.2","g","p","p eta [dilepton [e+ e-] g]","eta_dalitz",1,0,0,0);
    my_reaction.Do(histo1,"_x = [g+p]->M()");

    my_reaction.Print();
    my_reaction.Loop(10000);

}


The output is as follows:

 Reaction of 7 Particles interacting via 3 Channels
   Reaction Particles:
     0. quasi-particle (g beam and p target)
     1. p
     2. eta
     3. dilepton
     4. g
     5. e+
     6. e-
   Reaction Channels:
     1. g + p --> p + eta
        Interaction model(s):
        [beam_smear] Beam smearing
        [g + p_fix_p_eta] 2-body fixed mass, partial width {/}
        [g + p_genbod_p_eta] Pluto build-in genbod {/genbod}
     2. eta --> dilepton + photon (Dalitz)
        Interaction model(s):
        [eta_dalitz] Dalitz decay {/}
        [eta_genbod_g_dilepton] Pluto build-in genbod {/genbod}
     3. dilepton --> e+ + e-
        Interaction model(s):
        [dilepton_fixed_e-_e+] Fixed product masses {/}
        [dilepton_genbod_e-_e+] Pluto build-in genbod {/genbod}
        [eta_dilepton_helicity] Helicity angle of the dilepton decay of eta
   Bulk Classes:
     Epilogue: <PProjector> 
   Output Files:
     Root : eta_dalitz.root, all particles on file.
PReaction: calculating widths in PData...
Info in <PUtilsREngine::PUtilsREngine>: Random seed set to 60606
 20% done in 1.261318 sec
 40% done in 1.520687 sec
 60% done in 1.780155 sec
 80% done in 2.042362 sec
 100% done in 1.300976 sec
 CPU time 1.300000 sec


index.php?t=getfile&id=6920&private=0

Are you using maybe an older version?


  • Attachment: c1.png
    (Size: 8.94KB, Downloaded 282 times)


--
Ingo Froehlich
IKF - University of Frankfurt
069-798-47027, FAX: -47024
Re: Beam Smearing [message #13316 is a reply to message #13315] Thu, 12 April 2012 21:58 Go to previous message
Michael Kunkel is currently offline  Michael Kunkel
Messages: 53
Registered: June 2011
continuous participant
From: *hr.hr.cox.net
That was it. I seem to had forgotten to change my path of my libPluto.so in the script.

I hope this yields better results.

Thanks

Edit: Now that I am using the latest version, I see this warning with any PLUTO script I write


/PLUTO/pluto_v5.40/src/PBatch.h: In member function 'void PBatch::SetVarList(char*)':
/PLUTO/pluto_v5.40/src/PBatch.h:220: warning: declaration of 'x' shadows a member of 'this'


Everything works, just thought you should know.

EDIT:: This error is only seen when compiling ACLiC in ROOT

[Updated on: Wed, 18 April 2012 16:10]

Report message to a moderator

Previous Topic: [CLOSED] Turning ON/OFF Models
Next Topic: [SOLVED] GetBeam Function
Goto Forum:
  


Current Time: Wed Dec 01 13:50:00 CET 2021

Total time taken to generate the page: 0.02125 seconds