GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » dlopen error from parbase.so
dlopen error from parbase.so [message #12813] Mon, 28 November 2011 13:48 Go to next message
Olaf Hartmann is currently offline  Olaf Hartmann
Messages: 105
Registered: December 2003
Location: Wien-Alsergrund
continuous participant
From: *smi.oeaw.ac.at
Dear all,

I built a fresh PandaRoot version from the trunk (revision 13793), compiling went fine, however when loading the libraries I get an dlopen error:

root [0]   gROOT->LoadMacro("$VMCWORKDIR/gconfig/rootlogon.C");
root [1] rootlogon()
dlopen error: /u/olaf/panda/pandaroot/build_lenny64/lib/libParBase.so: undefined symbol: _ZN10FairLogger9GetLoggerEv
Load Error: Failed to load Dynamic link library /u/olaf/panda/pandaroot/build_lenny64/lib/libBase.so
(int)(-1)


Make clean, make, or a new cmake do not help ... any hint?

Cheers
Olaf.
Re: dlopen error from parbase.so [message #12814 is a reply to message #12813] Mon, 28 November 2011 13:53 Go to previous messageGo to next message
Florian Uhlig is currently offline  Florian Uhlig
Messages: 424
Registered: May 2007
first-grade participant
From: *pools.arcor-ip.net
Hi Olaf,

can you please check if you load the libFairTools before loading the libParBase.

Ciao

Florian
Re: dlopen error from parbase.so [message #12815 is a reply to message #12814] Mon, 28 November 2011 14:02 Go to previous messageGo to next message
Olaf Hartmann is currently offline  Olaf Hartmann
Messages: 105
Registered: December 2003
Location: Wien-Alsergrund
continuous participant
From: *smi.oeaw.ac.at
Hi Florian,

actually I did not load libFairTools at all ... it looks like it's not included in the default rootlogon or basiclibs macro ...

Ok, with that the error is gone.

Thanks
Olaf.
Re: dlopen error from parbase.so [message #12819 is a reply to message #12815] Mon, 28 November 2011 18:35 Go to previous messageGo to next message
Florian Uhlig is currently offline  Florian Uhlig
Messages: 424
Registered: May 2007
first-grade participant
From: *pools.arcor-ip.net
Hi Olaf,

i wonder why the library is not loaded. In my version of PandaRoot the library is already included in the rootlogon.C.
Something is strange with your installation. Are you sure that your VMCWORKDIR points to the correct directory?

Ciao

Florian
Re: dlopen error from parbase.so [message #12820 is a reply to message #12819] Mon, 28 November 2011 19:08 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *30-79-r.retail.telecomitalia.it
Also in my case it does work.
icon7.gif  Re: dlopen error from parbase.so [message #12821 is a reply to message #12819] Mon, 28 November 2011 19:15 Go to previous messageGo to next message
Olaf Hartmann is currently offline  Olaf Hartmann
Messages: 105
Registered: December 2003
Location: Wien-Alsergrund
continuous participant
From: *3.13.vie.surfer.at
Hi Florian and Stefano,

yes, the VMCWORKDIR was correct. I found the error in the meantime - my gconfig directory was not using the trunk from svn but my development branch. I forgot that I switched this some time ago.

Thanks for guiding my error diagnostics Smile

Cheers
Olaf.
Re: dlopen error from parbase.so [message #12822 is a reply to message #12821] Mon, 28 November 2011 20:56 Go to previous message
Florian Uhlig is currently offline  Florian Uhlig
Messages: 424
Registered: May 2007
first-grade participant
From: *pools.arcor-ip.net
Hi Olaf,

then this was not a clean checkout. Very Happy

Ciao

Florian
Previous Topic: TPC compilation problem
Next Topic: Problem with libgeant4vmc
Goto Forum:
  


Current Time: Fri Jun 14 18:29:31 CEST 2024

Total time taken to generate the page: 0.00978 seconds