GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » Not found tci for index
Not found tci for index [message #12727] Wed, 19 October 2011 13:00 Go to next message
rajududhat is currently offline  rajududhat
Messages: 17
Registered: May 2010
Location: Surat (India)
occasional visitor
From: *67.93.111.tataidc.co.in
Dear Friends

I got following error after updating the pandaroot (trunk) during run_sim_stt_evt.C

////////////////////////////////////////////

BBBB->33
cccc->12647
Info in <TGeoManager::CheckGeometry>: Fixing runtime shapes...
Info in <TGeoManager::CheckGeometry>: ...Nothing to fix
Info in <TGeoManager::CloseGeometry>: Counting nodes...
Info in <TGeoManager::Voxelize>: Voxelizing...
Info in <TGeoManager::CloseGeometry>: Building cache...
Info in <TGeoNavigator::BuildCache>: --- Maximum geometry depth set to 100
Info in <TGeoManager::CloseGeometry>: 1986492 nodes/ 3131 volume UID's in FAIR geometry
Info in <TGeoManager::CloseGeometry>: ----------------modeler ready----------------
====================================================
======= DRC:: ConstructOpticalGeometry() ========
Warning in <TGeant3TGeo::DefineOpSurface>: Called for surface MirrSurface. Not applicable in Geant3 - setting is ignored.
Warning in <TGeant3TGeo::SetBorderSurface>: Called for border surface BarMirrSurface. Not applicable in Geant3 - setting is ignored.
Warning in <TGeant3TGeo::SetBorderSurface>: Called for border surface BarMirrSurface. Not applicable in Geant3 - setting is ignored.
Warning in <TGeant3TGeo::SetBorderSurface>: Called for border surface BarMirrSurface. Not applicable in Geant3 - setting is ignored.
Warning in <TGeant3TGeo::SetBorderSurface>: Called for border surface BarMirrSurface. Not applicable in Geant3 - setting is ignored.
Warning in <TGeant3TGeo::SetBorderSurface>: Called for border surface BarMirrSurface. Not applicable in Geant3 - setting is ignored.
Warning in <TGeant3TGeo::SetMaterialProperty>: Called for material surface MirrSurface. Not applicable in Geant3 - setting is ignored.
Warning in <TGeant3TGeo::DefineOpSurface>: Called for surface EVSurface. Not applicable in Geant3 - setting is ignored.
Warning in <TGeant3TGeo::SetBorderSurface>: Called for border surface EVAirSurface. Not applicable in Geant3 - setting is ignored.
Warning in <TGeant3TGeo::SetMaterialProperty>: Called for material surface EVSurface. Not applicable in Geant3 - setting is ignored.
Warning in <TGeant3TGeo::DefineOpSurface>: Called for surface PDSurface. Not applicable in Geant3 - setting is ignored.
Warning in <TGeant3TGeo::SetBorderSurface>: Called for border surface EVPDSurface. Not applicable in Geant3 - setting is ignored.
Warning in <TGeant3TGeo::SetMaterialProperty>: Called for material surface PDSurface. Not applicable in Geant3 - setting is ignored.
======= DRC::ConstructOpGeometry -> Finished! ======
PndTpcDetector::SetSpecialPhysicsCuts() Working on medium TPCmixture

************************************************************
PndTpcDetector::SetSpecialPhysicsCuts():
using special physics cuts ...
using LOSS=5 for ALICE MC model
************************************************************
-I- Initializing PndSdsDetector()

************************************************************
PndEmc::SetSpecialPhysicsCuts():
using special physics cuts ...
************************************************************
-I- Initializing PndGemDetector()
-I- PndDrc: Intialization started...
-I- PndDrc: Switching OFF Cherenkov Propagation
bar 1 id = 3023
-I- PndDrc: Intialization successfull
[INFO ] Initialize Tasks--------------------------
INITIALIZATION *********************
Not found tci for index = 229000010 in PndEmcStructure
linux-1djg:/home/pandaroot/fairroot/trunk/macro/run/03MY/test #
//////////////////////////////////////

Plz help me regarding this.


Rajeshkumar G. Dudhat
SVNIT (INDIA)
Re: Not found tci for index [message #12728 is a reply to message #12727] Wed, 19 October 2011 13:11 Go to previous messageGo to next message
Dima Melnychuk is currently offline  Dima Melnychuk
Messages: 213
Registered: April 2004
Location: National Centre for Nucle...
first-grade participant
From: *fuw.edu.pl
Hi,

Due to changes in EMC code, numeration of EMC geometry versions has been changed but it was not updated in all the macros.

So, please check that in your macro in:
 	  PndEmc *Emc = new PndEmc("EMC",kTRUE);
 	  Emc->SetGeometryVersion(2);
 	  Emc->SetStorageOfData(kFALSE);
 	  fRun->AddModule(Emc);


Emc->SetGeometryVersion(2); or Emc->SetGeometryVersion(1);
is used.

Dima
Re: Not found tci for index [message #12729 is a reply to message #12728] Wed, 19 October 2011 13:45 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *to.infn.it
Hi,
if you are using run_sim_stt_evt.C, why the tpc geometry is appearing:

PndTpcDetector::SetSpecialPhysicsCuts() Working on medium TPCmixture

************************************************************
PndTpcDetector::SetSpecialPhysicsCuts():
using special physics cuts ...
using LOSS=5 for ALICE MC model
************************************************************


?
Maybe you have also messed up something else.
Re: Not found tci for index [message #12730 is a reply to message #12729] Wed, 19 October 2011 14:36 Go to previous message
rajududhat is currently offline  rajududhat
Messages: 17
Registered: May 2010
Location: Surat (India)
occasional visitor
From: *67.93.111.tataidc.co.in
Dear Friends

Thanks for solution.



Rajeshkumar G. Dudhat
SVNIT (INDIA)
Previous Topic: Trouble compiling FairModule starting from r13513
Next Topic: eta_c drop in efficiency
Goto Forum:
  


Current Time: Mon Apr 15 13:31:50 CEST 2024

Total time taken to generate the page: 0.01023 seconds