GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » Problem with GeoHandling
Problem with GeoHandling [message #11627] Thu, 07 April 2011 15:56 Go to next message
Sebastian Neubert is currently offline  Sebastian Neubert
Messages: 282
Registered: March 2006
Location: Munich
first-grade participant

From: *natpool.mwn.de
Dear colleagues,

I am currently trying to check the production chain with the TPC in order to prepare for the coming simulation campaigns and run into the error listed below. Do you have an idea what is going on?

Also we noticed that lately (r11177) there was a major redesign of the file-handling and the ErrorLogging. May this have to do with the observed crash? Has anybody been able to run with the new version of the code?

Cheers! Sebastian.

OBJ: FairRuntimeDb	FairRuntimeDb	Class for runtime database
Info in (PndGeoHandling::Instance): Making a new instance using the framework.
[INFO   ] Openning log file: ./FairLogfile_18562.log
 
[INFO   ] The input consists out of the following trees and files: 
[INFO   ]  - cbmsim 
[INFO   ]     - TEST/Test15deg.raw.root 
[INFO   ]  - FriendTree_1 
[INFO   ]     - TEST/Test15deg.mc.root 
-I-  Geometry was not found in the input file we will look in the friends if any!
[INFO   ] The number of entries in chain is 1000 

*************************************************************
     initialisation for run id 856637249
*************************************************************
Error in <FairBaseParSet::init()>: FairBaseParSet not initialized
Error in <FairRuntimeDb::initContainers()>: Error occured during initialization
PndTpcClusterFinderTask::SetParContainers
Fatal in <PndGeoHandling::PndGeoHandling>: No gGeoManager found.
aborting


Sebastian Neubert
Technische Universität München
Department Physik E18
sneubert@e18.physik.tu-muenchen.de
tel: +49-8928912592
Re: Problem with GeoHandling [message #11628 is a reply to message #11627] Thu, 07 April 2011 16:04 Go to previous messageGo to next message
Florian Uhlig is currently offline  Florian Uhlig
Messages: 424
Registered: May 2007
first-grade participant
From: *gsi.de
Hi Sebastian

Where did you store your parameter containers? The problem is that the parameter containers are not found and you end up without the geomanager.

Normally the containers are in a separate root file.

Ciao

Florian
Re: Problem with GeoHandling [message #11629 is a reply to message #11628] Thu, 07 April 2011 16:09 Go to previous messageGo to next message
Sebastian Neubert is currently offline  Sebastian Neubert
Messages: 282
Registered: March 2006
Location: Munich
first-grade participant

From: *natpool.mwn.de
Hi Florian,

thanks for the quick reply!
My parameters are in
TEST/Test15deg.raw.param.root
TEST/Test15deg.mc.param.root

The scheme I use works when reading in the MC for Digitization but it fails when I try to read in the digi stuff into the reco.

Sebastian.


Sebastian Neubert
Technische Universität München
Department Physik E18
sneubert@e18.physik.tu-muenchen.de
tel: +49-8928912592
Re: Problem with GeoHandling [message #11630 is a reply to message #11629] Thu, 07 April 2011 16:16 Go to previous messageGo to next message
Florian Uhlig is currently offline  Florian Uhlig
Messages: 424
Registered: May 2007
first-grade participant
From: *gsi.de
Hi Sebastian

In principle the idea behind the parameters is to store all in a single database. With the unique runid you can get the parameters from this database. Since up to now there is
no such database we still use the root files to store the required information. But also here the idea is to have only one file for a set of input data. So any additional parameter
container is stored in the same parameter file.

Could you please try to use the same parameter file for the complete chain of macros. This should solve the problem.

Ciao

Florian
Re: Problem with GeoHandling [message #11631 is a reply to message #11629] Thu, 07 April 2011 16:16 Go to previous messageGo to next message
Sebastian Neubert is currently offline  Sebastian Neubert
Messages: 282
Registered: March 2006
Location: Munich
first-grade participant

From: *natpool.mwn.de
Hi!

I have found the problem... I missed to add the mc.param.root as input to the database.
Also I tried to instantiate GEANE before I loaded the param database.

Now it seems to works.

Cheers! Sebastian.


Sebastian Neubert
Technische Universität München
Department Physik E18
sneubert@e18.physik.tu-muenchen.de
tel: +49-8928912592
Re: Problem with GeoHandling [message #11632 is a reply to message #11631] Thu, 07 April 2011 16:26 Go to previous message
Sebastian Neubert is currently offline  Sebastian Neubert
Messages: 282
Registered: March 2006
Location: Munich
first-grade participant

From: *natpool.mwn.de
Florian,

yes, this mode, using only one file, which is updated on very processing step, was what I was using so far. I only tried to use several files while debugging this issue.
But it's nice that you reconfirm, that the system should work like that, with a single database root file.

Cheers! Sebastian.


Sebastian Neubert
Technische Universität München
Department Physik E18
sneubert@e18.physik.tu-muenchen.de
tel: +49-8928912592
Previous Topic: Bug in EventDisplay
Next Topic: Broken libBase.so
Goto Forum:
  


Current Time: Sun Jul 14 09:43:07 CEST 2024

Total time taken to generate the page: 0.00781 seconds