GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Tracking » Lhe tracking results: reconstruction error for transverse momenta <= 1 GeV/c, all five particles
Lhe tracking results: reconstruction error for transverse momenta <= 1 GeV/c, all five particles [message #11227] Tue, 23 November 2010 18:09 Go to next message
David Pohl is currently offline  David Pohl
Messages: 18
Registered: October 2009
Location: FZ Juelich
occasional visitor

From: *ikp.kfa-juelich.de
Hallo everybody,

I just want to show you some results for the reconstruction error of the transverse momentum.
The following simulation parameters are used:

- Panda Root trunk version, revision 10334
- Geant3
- Boxgenerator with vertex (0,0,0)
- theta = 60°, phi = 0:360°
- one primary track per event, only primary tracks are taken into account in the analyses
- 1e4 events
- Lhe tracking package: ideal track finder + helix prefit + kalman task with correct particle hypothesis
- MVD+TPC+GEM tracking detectors, new MVD geometry: Mvd-2.1_AddDisks_FullVersion
- used particles: electrons, pions, myons, kaons and protons
- transverse momenta: 0,1; 0,2; 0,3; 0,4; 0,5; 0,6; 0,7; 0,8; 0,9; 1 GeV/c

The following plot shows the relative reconstruction error ||pt_MC|-|pt_reco||/|pt_MC| in percent:
index.php?t=getfile&id=6195&private=0

Every point is a Gausfit for the reconstructed transverse track momentum. The error bars are the sigmas of the fits.
Some examples are attached to this message.

One can see that the reco error for protons@300MeV/c pt and for kaons@200MeV/c is bad. The reason is a failed kalman fit.
This I already mentioned in the thread 'GENFIT for transverse momenta < 200 GeV/c strange?!'.

Also there was no track reconstruction for kaons and protons with a momentum <200MeV/c possible.
I think the low momentum particles stuck in the detector material and do not create enough hits?

Another interesting thing is a systematic offset of the reconstructed momentum for electrons:
index.php?t=getfile&id=6196&private=0

All offsets should be around zero. Especially this is not the case for lower momenta. Do you have an explanation for this?

By the way the kalman output for electrons doesn't look better than the helix prefit.
index.php?t=getfile&id=6205&private=0

greetings
David
Re: Lhe tracking results: reconstruction error for transverse momenta <= 1 GeV/c, all five partic [message #11228 is a reply to message #11227] Tue, 23 November 2010 23:30 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: 217.112.73*
Hi,
about the systematic shift of the electron residual, I think this could be correlated to bremsstrahlung, then the MC momentum is higher than the reconstructed one.
About bad resolution for protons and kaons, maybe you could try to plot the LheHit Y vs X so see if they are really helix or if they are too curly.
You shouls also check the angle resolution. If maybe the helix momentum is fine, but the theta is wrong, maybe the kalman is not able to fit the track properly.
Just trying to guess, I have never checked the reconstruction for other particles different from muons.
Re: Lhe tracking results: reconstruction error for transverse momenta <= 1 GeV/c, all five partic [message #11231 is a reply to message #11228] Wed, 24 November 2010 13:57 Go to previous message
David Pohl is currently offline  David Pohl
Messages: 18
Registered: October 2009
Location: FZ Juelich
occasional visitor

From: *ikp.kfa-juelich.de
Hi Stefano,

okay. This means that the Kalman task does not take the bremsstrahlung correctly into account?

The x-y plane plots for the LheHits are not to easy to judge.
I think to recognize cirlces is not easy for the human brain Razz .

On the first view one can assume that the kaons for 200 MeV/c transverse momenta do not lie on a circle.
Especially in the outer regions:
index.php?t=getfile&id=6206&private=0

Corresponding reconstructed transverse momenta:
index.php?t=getfile&id=6207&private=0

For 300 MeV/c transverse momenta the kaon tracks do not look that bent:
index.php?t=getfile&id=6208&private=0

Corresponding reconstructed transverse momenta:
index.php?t=getfile&id=6209&private=0

For electrons its an issue of the Kalman task I think:
index.php?t=getfile&id=6212&private=0

Corresponding reconstructed transverse momenta:
index.php?t=getfile&id=6213&private=0

Honestly I am at the moment quite busy with writing my thesis Confused and have no time to do dedicated "bug search".
I just wanted to show this issue to inform the tracking experts.

greetings,
David

p.s.: the plots in conformal mapping space are better to judge:
little bit bent
index.php?t=getfile&id=6214&private=0
straight line
index.php?t=getfile&id=6215&private=0

[Updated on: Wed, 24 November 2010 14:21]

Report message to a moderator

Previous Topic: GENFIT for transverse momenta < 200 GeV/c strange?!
Next Topic: PndTrack array available
Goto Forum:
  


Current Time: Mon May 20 15:19:32 CEST 2024

Total time taken to generate the page: 0.00810 seconds