GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » General » Problem installing External package
Problem installing External package [message #10858] Mon, 12 July 2010 12:10 Go to next message
Dipanwita Dutta is currently offline  Dipanwita Dutta
Messages: 25
Registered: May 2009
continuous participant
From: *gsi.de
Hi

I was trying to install External package(Jan10)
in linux SL5.

I got the following error:
ERROR: Camke could not be created

I tried to install cmake on my own, and
installed cmake-2.8.2 which is installed properly.

But then while running configure.sh
gives following error:

Found cmake version older than 2.6.3 PATH
This version is to old
***Compiling CMake...........


and then same error appear.

Please let me know how to proceed.

regards,
Dipanwita
Re: Problem installing External package [message #10860 is a reply to message #10858] Tue, 13 July 2010 11:59 Go to previous messageGo to next message
Mohammad Al-Turany is currently offline  Mohammad Al-Turany
Messages: 518
Registered: April 2004
Location: GSI, Germany
first-grade participant
From: *gsi.de
Hi,

Quote:


got the following error:
ERROR: Camke could not be created


can you please "cd" to $SIMPATH/basics/cmake directory and there:

>./bootstrap --prefix=$SIMPATH/basics/cmake
>make 
>make install


then post here the output of these commands, so that one see what is going wrong on your system.


Quote:

I tried to install cmake on my own, and
installed cmake-2.8.2 which is installed properly.

But then while running configure.sh
gives following error:

Found cmake version older than 2.6.3 PATH
This version is to old
***Compiling CMake...........



Ok, this is a bug in the install script, but in any case our cmake scripts are not compatible with Cmake 2.8.x! so you need 2.6.x


best regards

Mohammad




Re: Problem installing External package [message #10862 is a reply to message #10858] Wed, 14 July 2010 10:50 Go to previous messageGo to next message
Dipanwita Dutta is currently offline  Dipanwita Dutta
Messages: 25
Registered: May 2009
continuous participant
From: *gsi.de
Hello

First of all thanks for the prompt reply.

I tried to run
./bootstrap --prefix=$SIMPATH/basics/cmake
and the following error came in the terminal:

------------------------------------------
cmSystemTools.o: In function `cmSystemTools::RemoveRPath(std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::basic_string<char, std::char_traits<char>, std::allocator<char> >*, bool*)':
cmSystemTools.cxx:(.text+0x3b1): undefined reference to `cmELF::cmELF(char const*)'
cmSystemTools.cxx:(.text+0x3da): undefined reference to `cmELF::GetRPath()'
cmSystemTools.cxx:(.text+0x402): undefined reference to `cmELF::GetRunPath()'
cmSystemTools.cxx:(.text+0x480): undefined reference to `cmELF::GetDynamicEntryCount() const'
cmSystemTools.cxx:(.text+0x561): undefined reference to `cmELF::GetDynamicEntryPosition(int) const'
cmSystemTools.cxx:(.text+0x599): undefined reference to `cmELF::GetDynamicEntryPosition(int) const'
cmSystemTools.cxx:(.text+0x5d0): undefined reference to `cmELF::GetDynamicEntryPosition(int) const'
cmSystemTools.cxx:(.text+0x684): undefined reference to `cmELF::ReadBytes(unsigned long, unsigned long, char*) const'
cmSystemTools.cxx:(.text+0x714): undefined reference to `cmELF::~cmELF()'
cmSystemTools.cxx:(.text+0x72d): undefined reference to `cmELF::~cmELF()'
cmSystemTools.o: In function `cmSystemTools::CheckRPath(std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)':
cmSystemTools.cxx:(.text+0xf13): undefined reference to `cmELF::cmELF(char const*)'
cmSystemTools.cxx:(.text+0xf1e): undefined reference to `cmELF::GetRPath()'
cmSystemTools.cxx:(.text+0xf32): undefined reference to `cmELF::GetRunPath()'
cmSystemTools.cxx:(.text+0xfa5): undefined reference to `cmELF::~cmELF()'
cmSystemTools.cxx:(.text+0xfbe): undefined reference to `cmELF::~cmELF()'
cmSystemTools.o: In function `cmSystemTools::ChangeRPath(std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::basic_string<char, std::char_traits<char>, std::allocator<char> >*, bool*)':
cmSystemTools.cxx:(.text+0x10c9): undefined reference to `cmELF::cmELF(char const*)'
cmSystemTools.cxx:(.text+0x10f7): undefined reference to `cmELF::GetRPath()'
cmSystemTools.cxx:(.text+0x1124): undefined reference to `cmELF::GetRunPath()'
cmSystemTools.cxx:(.text+0x1600): undefined reference to `cmELF::~cmELF()'
cmSystemTools.cxx:(.text+0x1616): undefined reference to `cmELF::~cmELF()'
cmSystemTools.o: In function `cmSystemTools::GuessLibrarySOName(std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::basic_string<char, std::char_traits<char>, std::allocator<char> >&)':
cmSystemTools.cxx:(.text+0x19c3): undefined reference to `cmELF::cmELF(char const*)'
cmSystemTools.cxx:(.text+0x19e4): undefined reference to `cmELF::GetSOName(std::basic_string<char, std::char_traits<char>, std::allocator<char> >&)'
cmSystemTools.cxx:(.text+0x1bb6): undefined reference to `cmELF::~cmELF()'
cmSystemTools.cxx:(.text+0x1bcf): undefined reference to `cmELF::~cmELF()'
cmSystemTools.o: In function `cmELF::operator bool() const':
cmSystemTools.cxx:(.text._ZNK5cmELFcvbEv[cmELF::operator bool() const]+0xd): undefined reference to `cmELF::Valid() const'
collect2: ld returned 1 exit status
gmake: *** [cmake] Error 1
---------------------------------------------
Error when bootstrapping CMake:
Problem while running gmake

-------------------------------------------
I also attached the log file in Bootstrap.cmk/cmake_bootstrap.l
og herewith.

thanks and regards,
Dipanwita
Re: Problem installing External package [message #10863 is a reply to message #10862] Wed, 14 July 2010 11:09 Go to previous messageGo to next message
Florian Uhlig is currently offline  Florian Uhlig
Messages: 424
Registered: May 2007
first-grade participant
From: *gsi.de
Hi Dipanwita

Please remove the cmake directory and unpack the cmake tarfile once again.
Start with a clean build/source tree, this is a known issue with the bootstrap process.
If you run the bootstrap more than once you can get this error.

Ciao

Florian
Re: Problem installing External package [message #10864 is a reply to message #10863] Wed, 14 July 2010 13:05 Go to previous messageGo to next message
Dipanwita Dutta is currently offline  Dipanwita Dutta
Messages: 25
Registered: May 2009
continuous participant
From: *gsi.de
thanks, it worked.
regards,
Dipanwita
Re: Problem installing External package [message #10865 is a reply to message #10864] Wed, 14 July 2010 13:10 Go to previous message
Florian Uhlig is currently offline  Florian Uhlig
Messages: 424
Registered: May 2007
first-grade participant
From: *gsi.de
Hi Dipanwita

What did you do except removing the cmake directory?
On which platform (linux system and version) did you have the problems?

Ciao

Florian
Previous Topic: Changes for FairLinks
Next Topic: Problem with Root geometrys from CAD
Goto Forum:
  


Current Time: Tue Feb 27 16:04:07 CET 2024

Total time taken to generate the page: 0.00814 seconds