GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » Problems compiling EvtGen
Problems compiling EvtGen [message #7404] Fri, 10 October 2008 21:19 Go to next message
EDownie is currently offline  EDownie
Messages: 8
Registered: January 2007
Location: University ofGlasgow
occasional visitor
From: *physics.gla.ac.uk
Hi,

I've just compiled the latest external packages and pandaroot version and have been trying to compile EvtGen according to the instructions at http://panda-wiki.gsi.de/cgi-bin/view/Computing/EvtGen. Initially, I get a bunch of warnings like:
"makedepend: warning: /home/pandasim/fairsoft/cern/clhep/include/CLHEP/Vector/ZM xpv.h: non-portable whitespace encountered at line 201"
although the make depend part seems to finish OK. Then when I try the make bin part of the instructions, I get the error messages in the text file (attached). Can anyone help?

Thanks,

Evie

  • Attachment: EvtGenErrors
    (Size: 22.18KB, Downloaded 295 times)
Re: Problems compiling EvtGen [message #7405 is a reply to message #7404] Fri, 10 October 2008 21:31 Go to previous messageGo to next message
Mohammad Al-Turany is currently offline  Mohammad Al-Turany
Messages: 518
Registered: April 2004
Location: GSI, Germany
first-grade participant
From: *dip.t-dialin.net
Hi,

Did you also add the link options -lRIO -lSQL -lNet in the last step of the configuration?

Mohammad
Re: Problems compiling EvtGen [message #7407 is a reply to message #7404] Tue, 14 October 2008 11:52 Go to previous messageGo to next message
Andrey Zorin is currently offline  Andrey Zorin
Messages: 2
Registered: June 2008
occasional visitor
From: *jinr.ru
Very probably...

makedepend cannot find corresponding *.h file

Because gcc is not tuning.
I have written in config.mk follow string (path to *.h file):

EVTDEPINC=-I.
-DEVTSTANDALONE -I${CLHEP_BASE_DIR}/include -I${ROOTSYS}/include -I../ -I/usr/lib64/gcc/x86_64-pc-linux-gnu/4.1.2/include/g++-v4 -I/usr/lib64/gcc/x86_64-pc-linux-gnu/4.1.2/include/g++-v4/backward -I/usr/lib64/gcc/x86_64-pc-linux-gnu/4.1.2/include -I/usr/lib64/gcc/x86_64-pc-linux-gnu/4.1.2/include/g++-v4/x86_64-pc-linu x-gnu -I/usr/include


Paths will be for you lib configuration.

[Updated on: Tue, 14 October 2008 12:28]

Report message to a moderator

Re: Problems compiling EvtGen [message #7410 is a reply to message #7404] Tue, 14 October 2008 15:42 Go to previous message
EDownie is currently offline  EDownie
Messages: 8
Registered: January 2007
Location: University ofGlasgow
occasional visitor
From: *physics.gla.ac.uk
Hi Mohammad,

It's now compiling, I forgot the options -lRIO -lSQL -lNet as you suggested Embarassed .

Thank you for your help!

Cheers,

Evie
Previous Topic: PropagteToVolume Problem in GeanePro
Next Topic: gconfig G3Config.C SetCuts.C
Goto Forum:
  


Current Time: Mon Apr 22 08:33:22 CEST 2024

Total time taken to generate the page: 0.00709 seconds