GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » EvtGen searches for 64-bit include files
icon4.gif  EvtGen searches for 64-bit include files [message #7220] Mon, 25 August 2008 12:51 Go to next message
Jens Sören Lange is currently offline  Jens Sören Lange
Messages: 193
Registered: June 2005
first-grade participant
From: *dynamic.jyu.fi
Hi all,

some more problems with EvtGen.

Based upon an observation by Irina.

With the new external packages under suse 10.3

using the EvtGen configuration "gcc, g77, (nothing), -lRIO -lSQL -lNet" (which works fine the old external packages) it now starts searching for 64-bit include files (which I don't have on my 32-bit notebook). But there is nothing in the config.mk which could be changed (i.e. there is no 64-bit path in the config.mk).

soeren@pchad23:~/panda/pandaroot/trunk/pgenerators/EvtGen> make
Checking makedepend in EvtGen
make: *** No rule to make target `/usr/include/x86_64-linux/i386-linux/gnu/stubs.h', needed by `cgFinder.o'. Stop.

Any idea how to fix it?

P.S. Stefano can you maybe also put the solution for Irina's EvtGen "missing libshift" problem into the wiki? (also suse 10.3).

And who actually put the "EvtGen: use gfortran as your c++ compiler(!!) if you don't have g77" into the wiki. it seems to work(!) but we still don't understand why.

cheers, Soeren
Re: EvtGen searches for 64-bit include files [message #7221 is a reply to message #7220] Mon, 25 August 2008 13:14 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *physik.uni-giessen.de
Jens Soeren Lange wrote on Mon, 25 August 2008 12:51

Hi all,

some more problems with EvtGen.

Based upon an observation by Irina.

With the new external packages under suse 10.3

using the EvtGen configuration "gcc, g77, (nothing), -lRIO -lSQL -lNet" (which works fine the old external packages) it now starts searching for 64-bit include files (which I don't have on my 32-bit notebook). But there is nothing in the config.mk which could be changed (i.e. there is no 64-bit path in the config.mk).

soeren@pchad23:~/panda/pandaroot/trunk/pgenerators/EvtGen> make
Checking makedepend in EvtGen
make: *** No rule to make target `/usr/include/x86_64-linux/i386-linux/gnu/stubs.h', needed by `cgFinder.o'. Stop.

Any idea how to fix it?



It seems the last updated makefile have the local paths of Johan computer, where /usr/include/x86_64-linux exists.

You could try to remove all the stuff in Makefile starting from line 63 (cgfinder.o...), leaving the empty line. And you should try to remove the additional lines in the same way in EvtGenModels/Makefile and EvtGenBase/Makefile

Quote:


P.S. Stefano can you maybe also put the solution for Irina's EvtGen "missing libshift" problem into the wiki? (also suse 10.3).



First I should know what is the problem. I think Irina's problem was gfortran, which is not supported by EvtGen

Quote:


And who actually put the "EvtGen: use gfortran as your c++ compiler(!!) if you don't have g77" into the wiki. it seems to work(!) but we still don't understand why.



It did not work in my case (Gentoo), and neither in Irina's.
Re: EvtGen searches for 64-bit include files [message #7222 is a reply to message #7221] Mon, 25 August 2008 13:57 Go to previous messageGo to next message
Aleksandra Biegun is currently offline  Aleksandra Biegun
Messages: 64
Registered: May 2007
Location: Groningen
continuous participant
From: *KVI.nl
Hi Soeren, hi Stefano,

indeed, Johan added (14.08) into Makefile for EvtGen 2 links: -lMathCore -lThread and sent it to svn.
After that, EvtGen compiled.

Regards,
Ola.


Aleksandra Biegun
University of Groningen/KVI
Zernikelaan 25, 9747 AA Groningen
tel. +31 50 363 3630
fax. +31 50 363 4003
Re: EvtGen searches for 64-bit include files [message #7223 is a reply to message #7222] Mon, 25 August 2008 14:00 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *physik.uni-giessen.de
Yes,
but he forgot to remove all his local stuff in the Makefile.
Re: EvtGen searches for 64-bit include files [message #7225 is a reply to message #7220] Mon, 25 August 2008 14:53 Go to previous messageGo to next message
Tobias Stockmanns is currently offline  Tobias Stockmanns
Messages: 489
Registered: May 2007
first-grade participant
From: *ikp.kfa-juelich.de
I put the information on gfortran into the wiki page.

This idea is coming actually from Andrei and works for our Suse 10.2 and 11 installations but I have no idea why it works.

Cheers,

Tobias
Re: EvtGen searches for 64-bit include files [message #7246 is a reply to message #7220] Wed, 27 August 2008 11:10 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *physik.uni-giessen.de
The bug is now solved in svn, I have removed Johan's lines in the Makefile.

Re: EvtGen searches for 64-bit include files [message #7248 is a reply to message #7220] Wed, 27 August 2008 12:55 Go to previous messageGo to next message
Mohammad Al-Turany is currently offline  Mohammad Al-Turany
Messages: 518
Registered: April 2004
Location: GSI, Germany
first-grade participant
From: *gsi.de
Hi,

The problem is simply due to the fact the dependancy in EvtGen are written to the same Makefile. In my case I just call the confgure, then make depend in the main directory, EvtGenModels and EvtGenBase, and everything works fine!

So maybe we should re-write the makefiles in a proper way?


Mohammad
Re: EvtGen searches for 64-bit include files [message #7249 is a reply to message #7220] Wed, 27 August 2008 13:47 Go to previous messageGo to next message
Ralf Kliemt is currently offline  Ralf Kliemt
Messages: 507
Registered: May 2007
Location: GSI, Darmstadt
first-grade participant

From: 141.30.85*
Hi all,

I would suggest to even include the EvtGen compilation into the common compiling process (as shell script or similar). Would it hurt?

Ciao, Ralf.
Re: EvtGen searches for 64-bit include files [message #7251 is a reply to message #7248] Wed, 27 August 2008 14:20 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *physik.uni-giessen.de
This was already done.
Re: EvtGen searches for 64-bit include files [message #7255 is a reply to message #7251] Thu, 28 August 2008 10:13 Go to previous message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *physik.uni-giessen.de
Added:

The Makefiles of EvtGen were rewritten in the proper way, in svn, without the local lines.

But once you call the configure, they are updated with your local stuff. Of course one should commit code in svn without these addictions.

A lot of time ago we have agreed to have not EvtGen in the common compiling process, because it is difficult to mantain for the CERNLIB and other things. Of course we can change this policy, to have it in the Dashboard somehow.

Previous Topic: TPC error during compilation
Next Topic: CMake Problem Thread
Goto Forum:
  


Current Time: Thu May 26 06:49:57 CEST 2022

Total time taken to generate the page: 0.00779 seconds