GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » Problem compiling external packages on RedHat
icon5.gif  Problem compiling external packages on RedHat [message #5872] Wed, 13 February 2008 11:06 Go to next message
Jens Sören Lange is currently offline  Jens Sören Lange
Messages: 193
Registered: June 2005
first-grade participant
From: *
Hi, has anyone ever seen the following error when compiling
the new external packages? (when compiling proof)

cp proofd/inc/proofdp.h include/proofdp.h
gcc -g -pipe -m32 -Wall -W -fPIC -Iinclude -pthread -DINCLUDEDIR=\"/usr/include\" -DOBJSUFFIX=\".o\" -o build/rmkdepend/cppsetup.o -c build/rmkdepend/cppsetup.c
make: expand.c:489: allocated_variable_append: Assertion `current_variable_set_list->next != 0' failed.
./ line 657: 30423 Aborted make -j$number_of_processes

platform is
gcc 3.2.3
Red Hat Linux 9.0

thanks in advance, Soeren

[Updated on: Wed, 13 February 2008 12:20]

Report message to a moderator

Re: Problem compiling external packages on RedHat [message #5887 is a reply to message #5872] Fri, 15 February 2008 14:27 Go to previous message
Dmitry Morozov is currently offline  Dmitry Morozov
Messages: 34
Registered: May 2007
Location: Protvino, Russia
continuous participant
From: 194.190.166*
Dear Soeren,

I noticed the same error compiling the new external packages on SL3. And i found the solution. There is a bug in "make" package version 3.79. Update it to 3.80 or 3.81 (it can be downloaded from
This solved the problem for me.

Previous Topic: trajectories for particles with trackID > 0 missing
Next Topic: sigfault during EMC reco
Goto Forum:

Current Time: Tue May 21 06:32:58 CEST 2024

Total time taken to generate the page: 0.00959 seconds