GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » again EvtGen
again EvtGen [message #5511] Wed, 28 November 2007 12:52 Go to next message
Klaus Götzen is currently offline  Klaus Götzen
Messages: 293
Registered: June 2006
Location: GSI
first-grade participant
From: *ikf.physik.uni-frankfurt.de
Hi!

Somehow it's like a curse (or the Wiki is not up to date...)
I'd like to produce some events with the EvtGen. So I follow 100% the steps on the EvtGen Wiki, and the problems are:

/misc/cbmsoft/Debian3.1/cern/cernlib/2005 does not exist

therefore 'configure' doesn't work out of the box and ends with the messages

ls: /misc/cbmsoft/Debian3.1/cern/cernlib/2005/lib/libpythia*.a: No such file or directory
ls: /misc/cbmsoft/Debian3.1/cern/cernlib/2005/lib/libphotos*.a: No such file or directory
ls: /misc/cbmsoft/Debian3.1/cern/cernlib/2005/lib/libpdf*.a: No such file or directory

and therefore 'make bin' ends with

gcc -L. -L/misc/cbmsoft/Debian3.1/cern/cernlib/2005/lib/ -L/misc/cbmsoft/Debian3.1/new/cern/clhep/lib -L/misc/cbmsoft/Debian3.1/new/tools/root/lib -o testEvtGen testEvtGen.o -lEvtGen -lEvtGenModels -lEvtGenBase -lCLHEP -l -l -lpacklib -lmathlib -l -lCore -lCint -lHist -lGraf -lGraf3d -lGpad -lTree -lRint -lPostscript -lMatrix -lPhysics -ldl -lg2c -lnsl -lm
/usr/bin/ld: cannot find -l-l
collect2: ld returned 1 exit status
gmake: *** [bin] Error 1

Sorry to bother you always with the same problems, but maybe somebody could update the wiki (and tell me what to do, cause one forgets so quickly...)


Thanks and best regards,
Klaus
Re: again EvtGen [message #5512 is a reply to message #5511] Wed, 28 November 2007 12:59 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *physik.uni-giessen.de
Hi,
try with

/misc/cbmsoft/Debian3.1/old/cern/cernlib/2005

It seems the directory was moved without any notice, but it was there up to one week ago.
Re: again EvtGen [message #5513 is a reply to message #5512] Wed, 28 November 2007 13:05 Go to previous messageGo to next message
Klaus Götzen is currently offline  Klaus Götzen
Messages: 293
Registered: June 2006
Location: GSI
first-grade participant
From: *ikf.physik.uni-frankfurt.de
Hi Stefano!

Thanks, it worked now. I of course tried already with setting to the directory you mentioned, but it seems, that you have to login new or so, cause some other variables are apparently wrong then...

thanks anyway!

Klaus
Re: again EvtGen [message #5514 is a reply to message #5513] Wed, 28 November 2007 13:10 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *physik.uni-giessen.de
Hi,
CERN_ROOT was never inside the global "export" definition, you have always to so it by yourself, and than set the LD_LIBRARY_PATH.

So when you set teh pandaroot environment you do not have cernlib for free Smile
Re: again EvtGen [message #5515 is a reply to message #5511] Wed, 28 November 2007 13:13 Go to previous message
Florian Uhlig is currently offline  Florian Uhlig
Messages: 424
Registered: May 2007
first-grade participant
From: *gsi.de
Hi Klaus

cernlib can be found at /misc/cbmsoft/Debian3.1/old/cern/cernlib/2005.

About the rest i have no idea

Ciao

Florian
Previous Topic: Bugs in simulation
Next Topic: Energy-Loss in Geant3&4
Goto Forum:
  


Current Time: Fri Jan 28 20:14:59 CET 2022

Total time taken to generate the page: 0.00800 seconds