GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » CBM » CBM computing and communication infrastructure » SSH timeout on GSI-Machines?
icon9.gif  SSH timeout on GSI-Machines? [message #320] Thu, 15 April 2004 13:42 Go to next message
Michael Deveaux is currently offline  Michael Deveaux
Messages: 17
Registered: April 2004
Location: GSI / IReS Strasbourg
occasional visitor
Dear all,

connecting with SSH and Exceed, I regulary get logged out by the GSI-Computers. Probably due a timeout while I'm out for doing something else.

Even if it is a good training to restart everything you are working on after lunch, I wonder if there is a way to avoid this.

Best regards

Michael
Re: SSH timeout on GSI-Machines? [message #323 is a reply to message #320] Thu, 15 April 2004 15:17 Go to previous messageGo to next message
Walter F.J. Müller is currently offline  Walter F.J. Müller
Messages: 229
Registered: December 2003
Location: GSI, CBM
first-grade participant

Michael Deveaux wrote on Thu, 15 April 2004 13:42

...connecting with SSH and Exceed, I regulary get logged out by the GSI-Computers. ...


There are no timeout mechanisms in the SSH servers at GSI (I asked the system admin to confirm this !).

To identify and fix the problem we have therefore to be more quantitative:
  • what node(s) at GSI did you use ?
  • how often and at what times did this happen ?

Cheers, Walter


W.F.J.Müller, GSI, CBM, Tel: 2766
Re: SSH timeout on GSI-Machines? [message #328 is a reply to message #320] Mon, 19 April 2004 14:28 Go to previous message
Gabriel Stoicea is currently offline  Gabriel Stoicea
Messages: 1
Registered: April 2004
Location: National Institute for Ph...
occasional visitor
Dear Michael, Dear all,

I have the same problem between Bucharest and GSI in both ways. I studied a litle bit this problem and I get this answer from
openssh FAQ at http://www.openssh.com/faq.html :

2.12 - My ssh connection freezes or drops out after N minutes of inactivity.

This is usually the result of a packet filter or NAT device timing out your TCP connection due to inactivity. You can enable ClientAliveInterval in the server's sshd_config, or enable ServerAliveInterval in the client's ssh_config (the latter is available in OpenSSH 3.8 and newer).

Enabling either option and setting the interval for less that the time it takes to time out your session will ensure that the connection is kept "fresh" in the device's connection table.

Best regards,

Gabriel
Previous Topic: Is there any other list(s)? >>>
Next Topic: Problem with notification emails
Goto Forum:
  


Current Time: Wed Oct 20 10:02:20 CEST 2021

Total time taken to generate the page: 0.02114 seconds