GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » Problem with PndSttHitProducerIdeal
Problem with PndSttHitProducerIdeal [message #5786] Fri, 01 February 2008 13:15 Go to next message
Ralf Kliemt is currently offline  Ralf Kliemt
Messages: 507
Registered: May 2007
Location: GSI, Darmstadt
first-grade participant

From: 141.30.85*
Hi all,

While trying this geane tutorial number 2 I encountered a problem with the PndSttHitProducerIdel. I worked around by using the real hitproducer, but this is really time consuming.

Here goes the report: Everything seems to be ok at the beginning.
Toggle Spoiler

Then some events are processed and it breaks with this gdb output:
Toggle Spoiler


So something goes wrong maybe even inside root?
Ideas/workarounds?

Greetings from Dresden and have a nice weekend,
Ralf.


Edit:
I tried it with 10 events and it succeeded - maybe it has to do with a memory leak?
Ralf.

[Updated on: Fri, 01 February 2008 13:17]

Report message to a moderator

Re: Problem with PndSttHitProducerIdeal [message #5787 is a reply to message #5786] Fri, 01 February 2008 13:48 Go to previous messageGo to next message
asanchez is currently offline  asanchez
Messages: 350
Registered: March 2006
first-grade participant
From: *gsi.de
Hi Ralf, here from gsi,
it is running properly.

I don't get any crash by running the
ex2.

Maybe you are right and the problem is due to
root version???.

best regards
alicia.
Re: Problem with PndSttHitProducerIdeal [message #5788 is a reply to message #5787] Fri, 01 February 2008 14:06 Go to previous messageGo to next message
Aleksandra Biegun is currently offline  Aleksandra Biegun
Messages: 64
Registered: May 2007
Location: Groningen
continuous participant
From: *KVI.nl
Hi,

for me is the same situation like for Ralf and Alicia, i.e. indeed, at gsi, I don't have any problems with running all scripts
with GEANE (ex2), but at my computer runDIGI2.C macro crashed when I use PndSttHitProducerIdel.*
(the same problem as Ralf) and with the PndSttHitProducerReal.* hit producer works (but very slowly) and next scripts:
runRECO2.C and runPULL2.C work fine.


Best regards and have a nice weekend,
Ola.




Aleksandra Biegun
University of Groningen/KVI
Zernikelaan 25, 9747 AA Groningen
tel. +31 50 363 3630
fax. +31 50 363 4003
Re: Problem with PndSttHitProducerIdeal [message #5789 is a reply to message #5788] Fri, 01 February 2008 14:23 Go to previous messageGo to next message
Lia Lavezzi
Messages: 291
Registered: May 2007
Location: Torino
first-grade participant

From: *PV.INFN.IT
Hi all,
what kind of events are you simulating? Which particle, momentum, theta and phi angles? And how many events and track per event? I can try to simulate and digitize the same events and see what happens (I never saw such an error in STT...)

You could also try to change the seed in the runMC2.C macro
gRandom->SetSeed(12345)
and resimulate the events to see if it happens again...

Please let me know, ciao,
Lia.
Re: Problem with PndSttHitProducerIdeal [message #5790 is a reply to message #5789] Fri, 01 February 2008 15:06 Go to previous messageGo to next message
Aleksandra Biegun is currently offline  Aleksandra Biegun
Messages: 64
Registered: May 2007
Location: Groningen
continuous participant
From: *KVI.nl
Hi Lia,

adding a seed number helped
and now, everything is working fine,
also next macra.

Thanks a lot!

Best wishes and have a nice evening,
Ola.



Aleksandra Biegun
University of Groningen/KVI
Zernikelaan 25, 9747 AA Groningen
tel. +31 50 363 3630
fax. +31 50 363 4003
Re: Problem with PndSttHitProducerIdeal [message #5791 is a reply to message #5790] Fri, 01 February 2008 15:11 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *physik.uni-giessen.de
Well,
in each case there is still a problem somewhere, that does not appear by using a precise seed number...
Re: Problem with PndSttHitProducerIdeal [message #5792 is a reply to message #5791] Fri, 01 February 2008 15:34 Go to previous messageGo to next message
Lia Lavezzi
Messages: 291
Registered: May 2007
Location: Torino
first-grade participant

From: *PV.INFN.IT
Hi Ola and Stefano,
nice to hear that it works now, but Stefano is right: there is still something to be fixed.

I can try to reproduce the error if you tell me exactly what to simulate (maybe you can post your runMC2 macro) and if you could tell me also the seed you used... I' m afraid however that using a different machine will prevent me to reproduce exactly the same simulated events, even using the same seed in input, but we can try! Smile

Nice week end also to you all,
Lia.

Re: Problem with PndSttHitProducerIdeal [message #5794 is a reply to message #5792] Fri, 01 February 2008 15:47 Go to previous messageGo to next message
Aleksandra Biegun is currently offline  Aleksandra Biegun
Messages: 64
Registered: May 2007
Location: Groningen
continuous participant
From: *KVI.nl
Hi Lia,

I used exactly what is at svn (rev.2137), i.e.

- geometry: straws_skewed_blocks.geo
- momentum: 1.5 Gev
- theta: 0-180 deg
- phi : 0-360 deg
- magnetic field: SetField(0.,0.,20)
SetFieldRegion(-150,150,-150,150,-250,250)
- nEvents: 1000
- TGeant3
- seed number: 12345 (like you wrote Smile)

And, that's it.

As I mentioned, at gsi it works for me without any problem,
so maybe, indeed, you could not reproduce my problem,
but if you will try, would be nice, thanks.


Best wishes,
Ola.



Aleksandra Biegun
University of Groningen/KVI
Zernikelaan 25, 9747 AA Groningen
tel. +31 50 363 3630
fax. +31 50 363 4003
Re: Problem with PndSttHitProducerIdeal [message #5805 is a reply to message #5786] Mon, 04 February 2008 15:27 Go to previous messageGo to next message
Ralf Kliemt is currently offline  Ralf Kliemt
Messages: 507
Registered: May 2007
Location: GSI, Darmstadt
first-grade participant

From: 141.30.85*
Hello all,

I tried it with setting the random seed, too and this works. I have no clue why this happens.
When I put the random seed for the runMC2.C to the value you have at the MC output (it's 4357), I have the same effect - the ideal reco crashes at event 175.


Ciao, Ralf.
Re: Problem with PndSttHitProducerIdeal [message #5806 is a reply to message #5805] Mon, 04 February 2008 17:32 Go to previous messageGo to next message
Lia Lavezzi
Messages: 291
Registered: May 2007
Location: Torino
first-grade participant

From: *PV.INFN.IT
Hi Ralf,
I tried to reproduce the error, but with no success (even with the same seed... Sad). So there are two hypothesis: 1) my computer/compiler finds the bug but "ignores" it and proceeds, 2) the bug is linked to a rare event and since we have different machines the simulations, even starting from the same seed, are different and I don' t find that event.

I would ask you if you can send me your simulated root file (ex2.root), so that I can digitize it and see which is our case: if we are in case 1 I don' t know what to do at present (I will look if I can try it on another machine, with an older linux version), if we are in case 2 maybe I will be able to see the error (let' s hope this is our case Wink)

Ciao,
Lia.

Re: Problem with PndSttHitProducerIdeal [message #5829 is a reply to message #5786] Thu, 07 February 2008 10:27 Go to previous message
Lia Lavezzi
Messages: 291
Registered: May 2007
Location: Torino
first-grade participant

From: *pv.infn.it
Hi all,
I have been able (finally) to reproduce the error on another computer, and I see the crash at event 175 like you Ralf (I used your simulated file).
I tried to understand the bug source: in the hit producer two TClonesArray (fHitArray and fHitInfoArray) are created and registered to output; I saw that commenting out one of the two lines where the "new" is called, I mean:
the line: hit = new ((*fHitArray)[counter]) PndSttHit(detID, pos, dpos, iPoint, 0, closestDistance, closestDistanceError, wireDirection);
or the line: new ((*fHitInfoArray)[counter]) PndSttHitInfo(0, 0, trackID, iPoint, 0, kFALSE);
the bug disappears, but actually I don' t know what does this mean, does anyone have any idea?
It should not be due to a memory leak (I have been able to digitize an event with 170 hits, so 83 should not create problems), but I don' t know...
I checked the code, but I can' t find the actual error Sad
So this is my idea: I would suggest to wait and see if the bug will appear again with a future ROOT version (when we will update it: maybe it is connected with this version and it will disappear (I really hope so).
For the moment let' s keep the workaround of the seed changing. What do you think?
Ciao,
Lia.
Previous Topic: during make install: rootcint segmentation fault
Next Topic: trajectories for particles with trackID > 0 missing
Goto Forum:
  


Current Time: Thu Jun 13 01:56:15 CEST 2024

Total time taken to generate the page: 0.01001 seconds