GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » MVD » Root Geometry problems
icon4.gif  Root Geometry problems [message #4457] Mon, 11 June 2007 14:49 Go to next message
Ralf Kliemt is currently offline  Ralf Kliemt
Messages: 507
Registered: May 2007
Location: GSI, Darmstadt
first-grade participant

From: 141.30.85*
Hi Tobias,

I encountered these warning when using the rootfile geometry with Geant4:
Info in <TG4RootNavMgr::ConnectToG4>: ROOT detector construction class connected to G4RunManager
++++  TG4Warning:  ++++
    TG4PhysicsManager::SetProcess:
    Parameter RAYL is not implemented.
+++++++++++++++++++++++

++++  TG4Warning:  ++++
    TG4PhysicsManager::SetProcess:
    Parameter LABS is not implemented.
+++++++++++++++++++++++

++++  TG4Warning:  ++++
    TG4SDServices::GetVolumeID:
    Sensitive detector SensorActiveArea_[NrFE=5] is not defined.
+++++++++++++++++++++++

++++  TG4Warning:  ++++
    TG4SDServices::GetVolumeID:
    Sensitive detector SensorActiveArea_[NrFE=5]_PartAss is not defined.
+++++++++++++++++++++++

++++  TG4Warning:  ++++
    TG4SDServices::GetVolumeID:
    Sensitive detector SensorActiveArea_[NrFE=5] is not defined.
+++++++++++++++++++++++

++++  TG4Warning:  ++++
    TG4SDServices::GetVolumeID:
    Sensitive detector SensorActiveArea_[NrFE=5]_PartAss is not defined.
+++++++++++++++++++++++

++++  TG4Warning:  ++++
    TG4SDServices::GetVolumeID:
    Sensitive detector SensorActiveArea_[NrFE=8_oE] is not defined.
+++++++++++++++++++++++

++++  TG4Warning:  ++++
    TG4SDServices::GetVolumeID:
    Sensitive detector SensorActiveArea_[NrFE=8_oE]_PartAss is not defined.
+++++++++++++++++++++++

++++  TG4Warning:  ++++
    TG4SDServices::GetVolumeID:
    Sensitive detector SensorActiveArea_[NrFE=8_oE] is not defined.
+++++++++++++++++++++++



...


Does this mean there are still underscores in the detector names, which gives the trouble in G4?

Ciao, Ralf.

[Updated on: Mon, 11 June 2007 15:47]

Report message to a moderator

Re: Root Geometry problems [message #4463 is a reply to message #4457] Tue, 12 June 2007 10:30 Go to previous messageGo to next message
asanchez is currently offline  asanchez
Messages: 350
Registered: March 2006
first-grade participant
From: *gsi.de
Hi, the error with
the sensitive Volume is due to the underscore sign"_" in
the name.So if you remove the underscore, it will work.
I have actually had the same problem with my ge-detectors.

cheers ALicia.
Re: Root Geometry problems [message #4464 is a reply to message #4457] Tue, 12 June 2007 10:50 Go to previous message
Ralf Kliemt is currently offline  Ralf Kliemt
Messages: 507
Registered: May 2007
Location: GSI, Darmstadt
first-grade participant

From: 141.30.85*
Tobias removed the underscores.
The updated mvd geometry is in the svn.

Regards, Ralf.
Previous Topic: Geometry
Next Topic: FePixel and Pixel
Goto Forum:
  


Current Time: Tue Jul 23 17:25:30 CEST 2024

Total time taken to generate the page: 0.00655 seconds