GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » pandaroot installation on ubuntu16.04
pandaroot installation on ubuntu16.04 [message #19308] Wed, 01 June 2016 12:11 Go to next message
Simon Reiter is currently offline  Simon Reiter
Messages: 44
Registered: May 2013
continuous participant
From: *physik.uni-giessen.de
Hello,

I tried to install PandaRoot on Ubuntu 16.04, which is installed on an USB stick running on a MacBookPro. But that should not make any differences.
After some earlier problems with FairSoft and FairRoot which are pretty common ^^, I got to the installtion of PandaRoot itself.

An error occurred for PndLmdHitPair.cxx that the functions isinf and isnan could not be found. I looked in PndLmdSensorAlignment.cxx and saw, that both functions are called by std::isinf and std::isnan instead. Copying this call to PndLmdHitPair.cxx helped to finish the installation and it seems to work.

I just want to know if this can be added to the repo to prevent further problems or if this should not be done.

Best regards
Simon

PS: Please add to the wiki, that the installation of FairSoft is not supported by the newer versions (5+) of gcc, g++ and gfortran. Therefore I had to download 4.9 and relink the software in /usr/bin.

[Updated on: Wed, 01 June 2016 12:11]

Report message to a moderator

Re: pandaroot installation on ubuntu16.04 [message #19309 is a reply to message #19308] Wed, 01 June 2016 12:26 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *to.infn.it
Dear Simon,
I have installed successfully the suggested version of FairSoft, FairRoot and pandaroot trunk in my Ubuntu 16.04, and I am running gcc 5.3.1.
All those isnan are already corrected in the trunk since a while, when I sent the message in the forum. Which versions of FairSoft/FairRoot/pandaroot are you using?

[Updated on: Wed, 01 June 2016 13:18]

Report message to a moderator

Re: pandaroot installation on ubuntu16.04 [message #19310 is a reply to message #19308] Wed, 01 June 2016 15:22 Go to previous messageGo to next message
Simon Reiter is currently offline  Simon Reiter
Messages: 44
Registered: May 2013
continuous participant
From: *physik.uni-giessen.de
Hello Stefano,

I used the suggested version from the wiki like this:
  • FairSoft mar15p6
  • FairRoot v-15.11b
  • PandaRoot release jan16

I have the same gcc version (5.3.1) installed. I can now only remember that compilation of MillepedeII crashed with the newer gfortran version.
Re: pandaroot installation on ubuntu16.04 [message #19311 is a reply to message #19310] Wed, 01 June 2016 15:39 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *to.infn.it
That is the release suggested for the analysis, it is conservative and based on not so much modern operative systems, while modern OS are used by the developers.
If you want to use Ubuntu16.04, released last month, you have to use the trunk and the releases suggested for developers. The jan16 releases will not be updated.
Re: pandaroot installation on ubuntu16.04 [message #19312 is a reply to message #19308] Wed, 01 June 2016 15:46 Go to previous message
Simon Reiter is currently offline  Simon Reiter
Messages: 44
Registered: May 2013
continuous participant
From: *physik.uni-giessen.de
For now, it works, so it's fine for me now. I just wanted to mention it.
But this is good to know.
Previous Topic: Nov15 and Pythia problem
Next Topic: Seed in /macro/master/sim_complete.C
Goto Forum:
  


Current Time: Mon May 23 09:38:56 CEST 2022

Total time taken to generate the page: 0.00907 seconds