GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Event Generators » [FIXED] simpleEvtGen
[FIXED] simpleEvtGen [message #16633] Thu, 15 May 2014 16:53 Go to next message
Lu Cao is currently offline  Lu Cao
Messages: 77
Registered: February 2013
continuous participant
From: *ikp.kfa-juelich.de
Hi all,

I try to use simpleEvtGen/simpleEvtGenRO with the scurt14 #24910, but it doesn't work unfortunately. The printing out info is as following:

>./simpleEvtGenRO pbarpSystem dspair.dec 1000000 8.0 -1 

EvtGen:Initializing EvtGen
EvtGen:No random engine given in EvtGen::EvtGen constructor, will use default EvtSimpleRandomEngine.
EvtGen:Storing known decay models
EvtGen:Defining EvtBcToNPi model: Bc -> V + npi and Bc -> P + npi decays
from A.V. Berezhnoy, A.K. Likhoded, A.V. Luchinsky: Phys.Rev.D 82, 014012 (2010) and arXiV:1104.0808.
EvtGen:Main decay file name  :DECAY.DEC
EvtGen:PDT table file name   :evt.pdl
EvtGen:In readDecayFile, reading:DECAY.DEC
EvtGen:Expected to find a model name,found:PYTHIA on line 220
EvtGen:Will terminate execution!
Aborted


Here, the DECAY.DEC file is a copy of DECAY_2010.DEC in pandaroot/pgenerators/EvtGen/EvtGen/R01-03-00.

Could someone have a check or help to fix? Many thanks.

Best regards,
Lu

[Updated on: Fri, 16 May 2014 13:10] by Moderator

Report message to a moderator

Re: simpleEvtGen [message #16634 is a reply to message #16633] Thu, 15 May 2014 17:34 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: 37.227.151*
You should use DECAY.DEC and evt.pdl from Private folder.
Re: simpleEvtGen [message #16635 is a reply to message #16634] Thu, 15 May 2014 17:38 Go to previous messageGo to next message
Lu Cao is currently offline  Lu Cao
Messages: 77
Registered: February 2013
continuous participant
From: *ikp.kfa-juelich.de
Hi,

what do you mean by Private folder? I copied DECAY.DEC and put it in /buildpanda/bin/.

Best,
Lu
Re: simpleEvtGen [message #16636 is a reply to message #16635] Thu, 15 May 2014 18:25 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *ip71.fastwebnet.it
You should copy the DECAY.DEC and evt.pdl from pgenerators/EvtGen/EvtGen/Private, and not from pgenerators/EvtGen/EvtGen/R01-03-00.
Re: simpleEvtGen [message #16641 is a reply to message #16636] Fri, 16 May 2014 08:28 Go to previous messageGo to next message
Lu Cao is currently offline  Lu Cao
Messages: 77
Registered: February 2013
continuous participant
From: *ikp.kfa-juelich.de
Hi Stefano,

I tried it, but it only makes the simpleEvtGen work smoothly. The simpleEvtGenRO sitll doesn't work and the same error info is shown.


Best,
Lu
Re: simpleEvtGen [message #16642 is a reply to message #16641] Fri, 16 May 2014 08:53 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: 91.253.10*
Can you upload the decay.dec, evt.pdl and the .dec file you are using?
Re: simpleEvtGen [message #16643 is a reply to message #16642] Fri, 16 May 2014 08:56 Go to previous messageGo to next message
Lu Cao is currently offline  Lu Cao
Messages: 77
Registered: February 2013
continuous participant
From: *ikp.kfa-juelich.de
Sure. Here they are...

>./simpleEvtGenRO pbarpSystem dspair.dec 10 8.0 -1

best,
Lu
  • Attachment: DECAY.DEC
    (Size: 522.46KB, Downloaded 219 times)
  • Attachment: evt.pdl
    (Size: 74.46KB, Downloaded 215 times)
  • Attachment: dspair.dec
    (Size: 0.39KB, Downloaded 227 times)
Re: simpleEvtGen [message #16645 is a reply to message #16643] Fri, 16 May 2014 11:19 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *to.infn.it
Update your simpleEvtGenRO.cc, now it should be fixed. Do you also need in for the scrut14 or the trunk is enough?
Re: simpleEvtGen [message #16646 is a reply to message #16645] Fri, 16 May 2014 11:41 Go to previous messageGo to next message
Lu Cao is currently offline  Lu Cao
Messages: 77
Registered: February 2013
continuous participant
From: *ikp.kfa-juelich.de

Great!
Please also put it in the scrut14.

Thanks.

Lu
Re: simpleEvtGen [message #16647 is a reply to message #16646] Fri, 16 May 2014 11:47 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *to.infn.it
Done.
Re: simpleEvtGen [message #16649 is a reply to message #16647] Fri, 16 May 2014 13:08 Go to previous message
Lu Cao is currently offline  Lu Cao
Messages: 77
Registered: February 2013
continuous participant
From: *ikp.kfa-juelich.de

It works fine now:) Thanks.

Best,
Lu
Previous Topic: Event filtering for lambda and lambdabar in DPM
Next Topic: [FIXED] `simpleEvtGen` not working with scurt14 #25034
Goto Forum:
  


Current Time: Wed Feb 21 13:15:42 CET 2024

Total time taken to generate the page: 0.00901 seconds