GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » [FIX]
[FIX] [message #15672] Wed, 06 November 2013 15:43 Go to next message
Ralf Kliemt is currently offline  Ralf Kliemt
Messages: 507
Registered: May 2007
Location: GSI, Darmstadt
first-grade participant

From: *pool.mediaWays.net
Hi everybody.

The plots from last monday meeting (see here) showed strang result for the PRG fitter. I found the simple solution: For reasonable results one needs at least two iterations.
That's it.

I produced the plots again, doing two iterations in the PRG Fast, PRG Full and KinVtx fitters. You find them to be almost identical (for that clinical ensemble of tracks).
The very last plot shows off how much time was needed to run these algorithms. I.e. only the Fit() calls were measurted, not plotting the histograms and the used time is the "real time". One can see how the consumption is factors larger when compared to the POCA finder, as expectd.

Cheers
Ralf
Re: [FIX] [message #15675 is a reply to message #15672] Wed, 06 November 2013 16:28 Go to previous message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *to.infn.it
Great,
is it possible to modify the wiki tutorial, to write that if you use such PRG fitters you need to run it twice, and put some sample code?
Previous Topic: DipoleMap.0150.root does not exist ?
Next Topic: linking error
Goto Forum:
  


Current Time: Mon Jul 22 04:37:32 CEST 2024

Total time taken to generate the page: 0.00802 seconds