GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » [FIXED] Problems in compiling EvtGenDirect
[FIXED] Problems in compiling EvtGenDirect [message #14795] Fri, 24 May 2013 15:39 Go to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: 2.235.190*
Dear all,
I have troubles in compilation with my Mac. EvtGen does not compile due to some gfortran problem:

[ 45%] Built target EvtGen_exe_simpleEvtGenRO
[ 46%] Generating G__EvtGenDirectDict.cxx
Scanning dependencies of target EvtGenDirect
[ 46%] Building CXX object pgenerators/EvtGenDirect/CMakeFiles/EvtGenDirect.dir/PndEvtGenDirect.cxx.o
[ 46%] Building CXX object pgenerators/EvtGenDirect/CMakeFiles/EvtGenDirect.dir/G__EvtGenDirectDict.cxx.o
Linking CXX shared library ../../lib/libEvtGenDirect.so
ld: library not found for -lgfortran
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make[2]: *** [lib/libEvtGenDirect.0.0.0.so] Error 1
make[1]: *** [pgenerators/EvtGenDirect/CMakeFiles/EvtGenDirect.dir/all] Error 2
make: *** [all] Error 2



Before the cmake updates everything was smooth. Could some mac expert take a look?


[Updated on: Thu, 04 July 2013 12:29]

Report message to a moderator

Re: Problems in compiling EvtGenDirect [message #14796 is a reply to message #14795] Fri, 24 May 2013 15:46 Go to previous messageGo to next message
Florian Uhlig is currently offline  Florian Uhlig
Messages: 424
Registered: May 2007
first-grade participant
From: *gsi.de
Hi Stefano,

could you run

make VERBOSE=1

and post the last lines of the output to see the command which results in the error.

Ciao

Florian
Re: Problems in compiling EvtGenDirect [message #14797 is a reply to message #14796] Fri, 24 May 2013 15:56 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: 2.235.190*
Sure!

[ 45%] Built target EvtGen_exe_simpleEvtGen
make -f pgenerators/EvtGen/CMakeFiles/EvtGen_exe_simpleEvtGenRO.dir/build.make pgenerators/EvtGen/CMakeFiles/EvtGen_exe_simpleEvtGenRO.dir/depend
cd /Users/spataro/apr13/build && /Users/spataro/sep12/sep12build/bin/cmake -E cmake_depends "Unix Makefiles" /Users/spataro/apr13/pandaroot /Users/spataro/apr13/pandaroot/pgenerators/EvtGen /Users/spataro/apr13/build /Users/spataro/apr13/build/pgenerators/EvtGen /Users/spataro/apr13/build/pgenerators/EvtGen/CMakeFiles/EvtGen_exe_simpleEvtGenRO.dir/DependInfo.cmake --color=
make -f pgenerators/EvtGen/CMakeFiles/EvtGen_exe_simpleEvtGenRO.dir/build.make pgenerators/EvtGen/CMakeFiles/EvtGen_exe_simpleEvtGenRO.dir/build
make[2]: Nothing to be done for `pgenerators/EvtGen/CMakeFiles/EvtGen_exe_simpleEvtGenRO.dir/build'.
/Users/spataro/sep12/sep12build/bin/cmake -E cmake_progress_report /Users/spataro/apr13/build/CMakeFiles 
[ 45%] Built target EvtGen_exe_simpleEvtGenRO
make -f pgenerators/EvtGenDirect/CMakeFiles/EvtGenDirect.dir/build.make pgenerators/EvtGenDirect/CMakeFiles/EvtGenDirect.dir/depend
cd /Users/spataro/apr13/build && /Users/spataro/sep12/sep12build/bin/cmake -E cmake_depends "Unix Makefiles" /Users/spataro/apr13/pandaroot /Users/spataro/apr13/pandaroot/pgenerators/EvtGenDirect /Users/spataro/apr13/build /Users/spataro/apr13/build/pgenerators/EvtGenDirect /Users/spataro/apr13/build/pgenerators/EvtGenDirect/CMakeFiles/EvtGenDirect.dir/DependInfo.cmake --color=
make -f pgenerators/EvtGenDirect/CMakeFiles/EvtGenDirect.dir/build.make pgenerators/EvtGenDirect/CMakeFiles/EvtGenDirect.dir/build
Linking CXX shared library ../../lib/libEvtGenDirect.so
cd /Users/spataro/apr13/build/pgenerators/EvtGenDirect && /Users/spataro/sep12/sep12build/bin/cmake -E cmake_link_script CMakeFiles/EvtGenDirect.dir/link.txt --verbose=1
/usr/bin/c++  -m64 -g -O2 -Wshadow  -fno-inline -shared -flat_namespace -single_module -undefined dynamic_lookup   -o ../../lib/libEvtGenDirect.0.0.0.so -install_name /Users/spataro/apr13/build/lib/libEvtGenDirect.0.so CMakeFiles/EvtGenDirect.dir/PndEvtGenDirect.cxx.o CMakeFiles/EvtGenDirect.dir/G__EvtGenDirectDict.cxx.o -L/Users/spataro/apr13/apr13build/lib/root -L/Users/spataro/apr13/apr13build/lib ../../lib/libEvtGen.0.0.0.so -L/Users/spataro/apr13/apr13build//lib/root -lGui -lCore -lCint -lRIO -lNet -lHist -lGraf -lGraf3d -lGpad -lTree -lRint -lPostscript -lMatrix -lPhysics -lMathCore -lThread -lpthread -lm -ldl -lPythia6 ../../lib/libPhotos.0.0.0.so -lgfortran 
ld: library not found for -lgfortran
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make[2]: *** [lib/libEvtGenDirect.0.0.0.so] Error 1
make[1]: *** [pgenerators/EvtGenDirect/CMakeFiles/EvtGenDirect.dir/all] Error 2
make: *** [all] Error 2
MacBook-Pro-di-Stefano:build spataro$ 
Re: Problems in compiling EvtGenDirect [message #14798 is a reply to message #14795] Fri, 24 May 2013 16:46 Go to previous messageGo to next message
Andreas Pitka is currently offline  Andreas Pitka
Messages: 38
Registered: November 2011
Location: Gießen
continuous participant
From: *physik.uni-giessen.de
Have you tried to remove the standalone executables of EvtGen(simpleEvtGenRO...) from the CMakeLists.txt?

The problem is somehow related to the fortran compiler, i experienced something similar when using the intel fortran compiler.

Just try to run make -i, which continues making after the errors.

If thats the only error only the standalone executables of EvtGen are not build, which are not needed to run pandaroot.
Re: Problems in compiling EvtGenDirect [message #14799 is a reply to message #14797] Fri, 24 May 2013 16:48 Go to previous messageGo to next message
Florian Uhlig is currently offline  Florian Uhlig
Messages: 424
Registered: May 2007
first-grade participant
From: *gsi.de
Hi Stefano,

did you change anything in the build system?

Could you send me the CMakeLists.txt from pgenerators/EvtGenDirect.

Ciao

Florian
Re: Problems in compiling EvtGenDirect [message #14802 is a reply to message #14799] Fri, 24 May 2013 17:55 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: 2.235.190*
Hi, of course I did not change files, everything sits in the pandaroot trunk.

Here the link to the file.

[Updated on: Fri, 24 May 2013 18:30]

Report message to a moderator

Re: Problems in compiling EvtGenDirect [message #14926 is a reply to message #14798] Thu, 04 July 2013 12:15 Go to previous message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *to.infn.it
Fixed in the old and in the new EvtGen packages.

[Updated on: Thu, 04 July 2013 12:29]

Report message to a moderator

Previous Topic: [FIXED] method missing in RhoCandidate
Next Topic: [FIXED] Error while compling pandaroot in macbook pro
Goto Forum:
  


Current Time: Wed May 29 11:41:29 CEST 2024

Total time taken to generate the page: 0.01018 seconds