GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » Fairroot » General Discussion » trouble running event display
trouble running event display [message #14646] Sat, 20 April 2013 18:35 Go to next message
Raphael Cervantes is currently offline  Raphael Cervantes
Messages: 34
Registered: September 2012
Location: Stony Brook University
continuous participant
From: *dyn.optonline.net
Hey guys, I'm having trouble running event display. I'm trying to use fairbase as is without any modifications, so I don't understand why it is not working. I have tried using both the sep12 and april13 external packages, but I have had no luck. This is the error message that I get:
root -l eventDisplay.C
root [0]
Processing eventDisplay.C...
FairRootManager::OpenOutFile("data/test.root")
[INFO ] The input consists out of the following trees and files:
[INFO ] - cbmsim
[INFO ] - data/test.mc.root
-I- name parset # FairBaseParSet
-I- RTDB entries in list# 1
[INFO ] Parameter and input file are available, Assure that basic info is there for the run!
[INFO ] The number of entries in chain is 10
[INFO ] Branch: EventHeader. not found in Tree
[INFO ] Branch: EventHeader. not found in Tree
[INFO ] No event Header was found!!!
[INFO ] Branch: EventHeader. not found in Tree
[INFO ] Branch: EventHeader. not found in Tree

************************************************************* 1
initialisation for run id 1366474914
************************************************************* 2
-I- FairRunTimeDB::InitContainer() FairBaseParSet
[ERROR ] init() FairBaseParSet not initialized
Error in <FairRuntimeDb::initContainers()>: Error occured during initialization

************************************************************* 1
initialisation for run id 1366474914
************************************************************* 2
-I- FairRunTimeDB::InitContainer() FairBaseParSet
[ERROR ] init() FairBaseParSet not initialized
Error in <FairRuntimeDb::initContainers()>: Error occured during initialization

************************************************************* 1
initialisation for run id 1366474914
************************************************************* 2
-I- FairRunTimeDB::InitContainer() FairBaseParSet
[ERROR ] init() FairBaseParSet not initialized
Error in <FairRuntimeDb::initContainers()>: Error occured during initialization
Re: trouble running event display [message #14647 is a reply to message #14646] Sat, 20 April 2013 21:57 Go to previous messageGo to next message
Mohammad Al-Turany is currently offline  Mohammad Al-Turany
Messages: 518
Registered: April 2004
Location: GSI, Germany
first-grade participant
From: *dip0.t-ipconnect.de
Hallo Raphael,

are you using the trunk version of fairroot? Currently we are re-designing the parameter interface so not every thing is running as it should be, please use the tags and not the trunk.


svn co https://subversion.gsi.de/fairroot/fairbase/tags/v-13.03a

regards,

Mohammad
Re: trouble running event display [message #14649 is a reply to message #14647] Mon, 22 April 2013 04:31 Go to previous messageGo to next message
Raphael Cervantes is currently offline  Raphael Cervantes
Messages: 34
Registered: September 2012
Location: Stony Brook University
continuous participant
From: *dyn.optonline.net
I was using the trunk version of fairroot. Thank you for the heads up.
Re: trouble running event display [message #14652 is a reply to message #14647] Mon, 22 April 2013 12:02 Go to previous messageGo to next message
Denis Bertini is currently offline  Denis Bertini
Messages: 6
Registered: February 2004
Location: GSI
occasional visitor
From: *gsi.de
Hi Raphael,

The tutorial3 with eventDiplay.C is now working.
Please update the fairbase trunk and recompile.

Thanks for reporting.

regards,
Denis
Re: trouble running event display [message #14653 is a reply to message #14652] Mon, 22 April 2013 18:54 Go to previous messageGo to next message
Raphael Cervantes is currently offline  Raphael Cervantes
Messages: 34
Registered: September 2012
Location: Stony Brook University
continuous participant
From: *physics.sunysb.edu
I have also found that event display does not show the proton track. Is that true for anyone else?
Re: trouble running event display [message #14751 is a reply to message #14647] Fri, 10 May 2013 16:59 Go to previous messageGo to next message
Raphael Cervantes is currently offline  Raphael Cervantes
Messages: 34
Registered: September 2012
Location: Stony Brook University
continuous participant
From: *physics.sunysb.edu
Hi Mohammad,
I am trying to switch over to the new tag 13.05
I tried svn co https://subversion.gsi.de/fairroot/fairbase/tags/v-13.05
but get the following error:
svn: E175002: The OPTIONS request returned invalid XML in the response: XML parse error at line 1: Extra content at the end of the document
(https://subversion.gsi.de/trac/fairroot/fairbase/tags/v-13.05)

Do you know what may possibly be the cause?

Best,
Raphael
Re: trouble running event display [message #14752 is a reply to message #14751] Sun, 12 May 2013 17:15 Go to previous message
Mohammad Al-Turany is currently offline  Mohammad Al-Turany
Messages: 518
Registered: April 2004
Location: GSI, Germany
first-grade participant
From: *dip0.t-ipconnect.de
Hallo Raphael,

We had some problems with the SVN server last week, I tried it today and it seems to work now. could you try again?

Mohammad
Previous Topic: Fairroot compiler errors: when building current pandaroot revision (19615)
Next Topic: FairRunAna::SetGeomFile seems not to work
Goto Forum:
  


Current Time: Sat Dec 04 04:46:56 CET 2021

Total time taken to generate the page: 0.01946 seconds