GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » Fairroot » General Discussion » Running Pythia input on Geant4 not working
Running Pythia input on Geant4 not working [message #13726] Mon, 09 July 2012 22:21 Go to next message
Raghav Kunnawalkam is currently offline  Raghav Kunnawalkam
Messages: 63
Registered: February 2012
Location: Stony Brook, New York
continuous participant
From: *physics.sunysb.edu
Hi All

I can successfully run a pythia6 output file into my detector using Geant3 but the same when it try to do Geant4 does not work.

I do have Geant4 working and it all works if i just create a particle using fairboxgenerator and shoot it. But the problem only arises when i try to use pythia output as the input to my detector.

Here is the error message that root tells me (after telling me a lot about geant4)

### Run 0 start.
[INFO ] [09.07.2012 16:04:58] [FairPrimaryGenerator.cxx::GenerateEvent:170] FairPrimaryGenerator: (Event 1) 27 primary tracks from vertex (0.000000, 0.000000, 0.000000 ) Event Time = 0.000000 (ns)

TG4PrimaryGeneratorAction::TransformPrimaries:
G4ParticleTable::FindParticle() failed for string pdgEncoding=92.
*** TG4Exception: Aborting execution ***

WARNING - Attempt to delete the physical volume store while geometry closed !
WARNING - Attempt to delete the logical volume store while geometry closed !
WARNING - Attempt to delete the solid store while geometry closed !
WARNING - Attempt to delete the region store while geometry closed !
Warning in <TStreamerInfo::Build:>: TStreamerBase: base class TStreamerElement has no streamer or dictionary it will not be saved
raghav:macros raghav$

I also dont know why those warnings are always appearing. So far i am just ignoring them and it seems that there is no problem.

Thanks for your help
Cheers
Raghav
Re: Running Pythia input on Geant4 not working [message #13759 is a reply to message #13726] Mon, 16 July 2012 12:27 Go to previous messageGo to next message
Mohammad Al-Turany is currently offline  Mohammad Al-Turany
Messages: 518
Registered: April 2004
Location: GSI, Germany
first-grade participant
From: *gsi.de
Hallo Raghav,

In your Pythia reader you have to select only stable particles to be transported i.e.:

             ncols = fscanf(fInputFile,"%d %d %d %d %d %f %f %f %f %f %f %f", &nLev, &pdgID, &nM1, &nDF, &nDL, &fPx, &fPy, &fPz, &fE, &fVx, &fVy, &fVz);
             if(nLev==1)  primGen->AddTrack(pdgID, fPx, fPy, fPz, fVx, fVy, fVz);



otherwise you can have the case that Geant4 does not know your intermediate particle and thus cannot transport it. In case you need to have the intermediate particles in your stack without transporting them, this is possible but this is another topic now. (In Panda they use this option)


regards,

Mohammad
Re: Running Pythia input on Geant4 not working [message #13760 is a reply to message #13759] Mon, 16 July 2012 15:53 Go to previous message
Raghav Kunnawalkam is currently offline  Raghav Kunnawalkam
Messages: 63
Registered: February 2012
Location: Stony Brook, New York
continuous participant
From: *physics.sunysb.edu
Hi Mohammad

Thanks for your reply. I get it now. I actually had that line and commented it out thinking that i needed all the tracks.

Cheers
Raghav
Previous Topic: Units for geometry in .geo files and in root. And FairDetectorPoint questions
Next Topic: Looking at all the events simultaneously in Event display
Goto Forum:
  


Current Time: Tue May 28 19:09:04 CEST 2024

Total time taken to generate the page: 0.00954 seconds