GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » Trouble compiling FairModule starting from r13513
Trouble compiling FairModule starting from r13513 [message #12705] Fri, 07 October 2011 17:40 Go to next message
Francesco Cusanno is currently offline  Francesco Cusanno
Messages: 2
Registered: June 2011
occasional visitor
From: *natpool.mwn.de
Hi,

I am using the trunk version of the external packages and I get compilation error on FairModule starting from revision 13513.
It sounds to be related to the fixing of the bug in Eta_c digitization, but I am not sure.
Am I doing something wrong? I do not find anything about that on the forum.
Just reverting FairModule to r13512 works, even if I get some warnings in running my macros.

Francesco
Re: Trouble compiling FairModule starting from r13513 [message #12706 is a reply to message #12705] Fri, 07 October 2011 18:31 Go to previous messageGo to next message
Mohammad Al-Turany is currently offline  Mohammad Al-Turany
Messages: 518
Registered: April 2004
Location: GSI, Germany
first-grade participant
From: *dip.t-dialin.net
Hi,

What kind of error you get? and which external packages you use?

if you use something older than may11, then it could be that you are missing the GDML stuff in your root compilation. in case of jan10 or feb11 externals just go to your $SIMPATH and call svn update. This will update tools/rootconfig.sh. After that delete $SIMPATH/tools/root/bin/root.exe and run the configure.sh in $SIMPATH, this will reconfigure and build ROOT with gdml.

Regards

Mohammad

Re: Trouble compiling FairModule starting from r13513 [message #12707 is a reply to message #12706] Mon, 10 October 2011 15:02 Go to previous message
Francesco Cusanno is currently offline  Francesco Cusanno
Messages: 2
Registered: June 2011
occasional visitor
From: *natpool.mwn.de
Thank you very much Mohammad,

indeed the issue was due to the old configuration of my ROOT, which was missing gdml.

Francesco
Previous Topic: bug in Eta_c digitization
Next Topic: Not found tci for index
Goto Forum:
  


Current Time: Fri Apr 19 08:26:53 CEST 2024

Total time taken to generate the page: 0.00849 seconds